New un-installation tool for CAV beta 1.1

Hi All,

We have faced some problems in uninstalling CAV beta 1.1 which was using InstallShield to install/uninstall. To resolve this problem we have made un-installation utility. It will do total un-installation of CAV beta 1.1.

Please follow these steps

  1. Download UninstallCAV1.1.zip attached in this post.
  2. Extract UninstallCAV1.1.zip to get UninstallCAV1.1.exe
  3. Copy UninstallCAV1.1.exe to “Comodo AntiVirus” folder i.e CAV installation path. (The default installation path for CAV is %program files%\Comodo\ Comodo AntiVirus.
  4. Run UninstallCAV1.1.exe and click Uninstall button. It will un-install CAV beta.1.1 completely.

In case some one has deleted the “Comodo AntiVirus” folder manually, he can reinstall CAV beta 1.1 and then follow the above steps for complete un-installation of CAV beta 1.1.

To reinstall CAV 1.1
If you dont have CAV 1.1 setup, click here to download http://www.antivirus.comodo.com/download/setup.exe

The complete un-installation will fix “Windows installer popups for CAV” bug.

Thanks & regards
Kishor

[attachment deleted by admin]

This is fantastic, thank you - this will help a lot of people when they come to remove 1.1 and install the new CAVS 2.

:BNC

Thankyou so much Kishork. We all know about the length of time this has taken, but a successful resolution goes a long way towards restoring faith. And let other free software providers look on in awe at the amount of support that has gone into resolving this issue with free beta software.

:■■■■

Well after a long battle, I can report the fix doesn’t work (at least for my machine)
I got it to the point where the popups would just blink.
So I followed the instructions. Reinstalled the a/v and put the uninstall to work.

Now, every time I start office I get the installer message. Office will start but it takes about 2 minutes of waiting for the installer to finish and give me the normal error message about reinstalling or repairing the application ( I did this in the past and it doesn’t work)

So I think I will try one of the other listed fixes (I didn’t try it because it wasn’t annoying)
Sorry to report this but just know I really appreciate the fact you tried to get this repaired.

I’ll report back after I try the other fix (Little Mac & I have had conversations and I believe its his repair)

Thanks again for the help,
Keep trying :slight_smile:

Dr Pete

Well I’m glad you guys made an uninstall utility… though I haven’t been able to try it.
It’s sort of funny that I am reading this after two reboots since trying to uninstall Comodo AV, which I did successfully :BNC (using only the registry backup, CCleaner, Process Explorer, and zipping everything for backup 8)).
I will still follow the progress of Comodo AV (and will be using Comodo PFirewall of course) though I am, for now, switching to a more stable AV.
Great job though- Comodo AV was great when I used it (except for some problems with thunderbird which is why I wanted to get rid of it) (V).

-Romain B.

PS: First post, and it’s not even to ask for help (:KWL)

Hi DrPete,
Can you pls attach the windows installer popup message?

Thanks & regards
Kishor

For the benefit of those (like myself) that didn’t install CAV into the default directory, and in an effort to uninstall it, removed any reference to “Comodo” from the Windows directory and the registry… is there a file or registry entry that I could search for in order to get some indication of what the install directory was? It’s not that I have a bad memory, rather a ton of drives and have been waiting for a removal utility for a long time.

Any help you are able to provide would be greatly appreciated!

Hi Kishork,
Here are the screen shots.
#1 comes up first when I try to start word.
After I click OK, 2 minutes later I get the #2 screen.
After I click OK again word starts OK.

I am going to try the manual instructions provided earlier by Little Mac.
I’ll report back if I am successful.

Report back…
Tried the uninstall using zsoft uninstaller, the annoying popup is still there.
I think its time to give up on this one and do a reformat ! No big deal, would have been nice to clean this up thou.

Thanks,
Dr Pete

[attachment deleted by admin]

I don’t know if this will help anyone here and I have not tried any of the files but the following site has some Windows XP File Association Fixes in the form of zip files. There is one for restoring default associations for MSI files.
May be no use and I have not tried any of the fixes (mainly cos I don’t need to fix anything just now) but thought I should put the link here in case anyone wishes to see if any of the fixes are useful.

http://www.dougknox.com/xp/file_assoc.htm

:SMLR

Hmmmm. When I click the attachment I get this message:

“404 - Attachment Not Found”

I ran “uninstallCAV1.1.exe”, but the folder, “Comodo Antivirus” and many, many files within this folder remain, including one, dated today, called, “UnInstCAV1_1Log.txt”. This file’s text follows below. Was the deinstallation successful, and if not, what’s my problem and what’s my solution?

Thank you.

text:

CAV Uninstallation started On 4/25/2007–11:25:10 PM

Removal of Uninstall entries failed
Removal of component registration information was successful
COM(s) Un-Registration failed
LSP utility executed successfully
Uninstaller utility executed successfully
create Processrundll32.exe setupapi,InstallHinfSection DefaultUninstall 128 C:\Program Files\Comodo\common\CAVASpy\cavasm2k.inf
infinte wait for single object
wait for single object finished
create ProcessC:\Program Files\Comodo\common\CAVASpy\cavasm /UnregServer
infinte wait for single object
wait for single object finished
DriverUnInstall() returned false
Registry data removed successfully
Some files/Directories failed to delete

Hi tryagain,
Pls. run again “uninstallCAV1.1.exe” from “Comodo AntiVirus” folder and see if it deletes the remaing files/folders.

regards
Kishor