New Private Network Detected ??

My electric power did a real quick off/on, but not long enough to turn off the PC. When I looked there was a message window stating:

New Private Network Detected

The Firewall has detected a new private network that your PC is about to join.
You may either close this window or follow the steps shown the screen.

Step 1 - Give a name to this network….
Local Area Network #1 (was an example given)

Step 2 - Decide if you want to trust the other PCs in this network

O - I would like to be fully accessible to the other PCs in this network
Select only to enable file/folder/printer and/or internet connection sharing
(e.g. for your home or office networks)

O - Do not automatically detect the new networks


There is no option to select do NOT join the network. So I turned off the PC & modem & rebooted, but the message was still there. There was a dual URL addressed displayed & I wrote it down. However upon rebooting only a single address appears. Just looked again and a different dual address shows again.

Right now I have not clicked on anything.
I only have one PC and therefore am not networked to anything.

Where the heck did a new private network come from?
Any suggestions on how to proceed?

What was the IP address of the new network?

I wrote it the address on the back of an envelope which I’m looking for. But do recall it started with 169 and the second part was 255.255.

Therefore something like 169.x.x.x / 255.255.x.x.

When the message said New Private Network Detected I took this to mean a new additional network. I’m not real familiar with networks because I do not have or use one. But could this mean that if my DSL modem was cycled off/on that it could have established a new address, or something to that effect? I’ve had power glitches before & never saw any Comodo message like I mentioned. However usually a power outage lasts long enough to shut off the PC also. But this time it was a really quick flicker.

Presuming it is just the modem setting up a new address, what is correct answer that I should have given? I do not want to give it a new name because I already have a name for my LAN. And I do not want to enable any file sharing. And I don’t think I should turn off the auto detect new networks - or should I? I guess I would like to be aware of what is going on.

But what happens if I just close the message window? Does that mean I am not protected?

Sorry for all the questions, but I do not have a lot of experience with networks.

Aha!! It was probably 169.254.something.something. This is safe.

There are several private address ranges - 192.168.X.X, 172.16.31.X and 10.X.X.X. These private addresses are for use within private LANs and will not be encountered on the internet. There is another peculiar address range - 169.254.X.X.

This is called APIPA ( Automatic Private IP Addressing) and is used when you are on a network and your PC cannot reach the DHCP server to be given an IP address. Where a workstation can’t reach the DHCP server, the operating system will allocate an APIPA address to the network adaptor to keep the adaptor “alive”.

This scenario fits with your power outage incident. Your PC didn’t go down, but your router probably did, which meant your network card lost its address and the O/S gave it an APIPA one. When you have real outages in the past, both devices went down and, assumedly, both came back up.

Hope this helps,
Ewen :slight_smile:

P.S> It is safe to make a rule to alow in or out access to/from addresses inthe range 169.254.1.X to 169.254.10.X.

Thank you for your reply & information.

I found my note and wrote 169.24.x.x. Maybe I made a mistake and it was really 169.254.x.x.

OK, it is safe to allow it access. But what happens now that the modem is back on online? If the APIPA address was used to keep the adapter “alive”, what happens when that address is not needed anymore because the modem is now back on? Do I end up with 2 private addresses or does one take precedence over the other?

In my case I closed the message window & everything still worked. Did another address get assigned because the modem was back on?

If I look at Local Area Connections on my PC it shows IP address of 75.57.x.x and assigned by DHCP. This is not one of the ranges that you mentioned, but is it still OK?

Thanks again.

When your PC cant contact your modem to get an IP address from the modems DHCP server, then its operating system will allocate it an APIPA address. If it doesn’t have a static IP address, it will nexta attempt to get a DCHP IP address. Then and only then will it give itself an APIPA address. There is an order and a priority in all this.

Ewen :slight_smile:

I guess my basic question is what what happens to the allocated APIPA address after I turn the modem back on? Does the APIPA address “stick”, or does the DHCP server assign another new address and wipe out the “old” APIPA one?

A quick way to force it to reacaquire a DHCP addresses is to ENABLE - DISABLE the network adaptor. This can be easily done by right clicking the metword adaptors system tray icon (XP) or through teh network and Shapring Centre (Vista/7).

Ewen :slight_smile:

i have a related question…how can i go back and allow other devices on the network to be "“trusted” after i intially blocked them when the network was recognized?
thanks!

Easy. Find their entries in either the Defense+ rules or the firewall rules and DELETE them. Next time you stsart those apps, you should get asked again and can respond correctly this time.

Hope this helps,
Ewen :slight_smile:

HI Ewen. Thanks for the quick response. I might be misunderstanding you here, but I wasnt talking about an application, I was talking about my LAN privacy settings in relation to my computer. I want to allow my xbox and my PC to share on my router.

Thanks again!

You need to make your local network a trusted zone.

First look up your IP address and subnet mask. In Windows go to Start → Run → cmd → enter → ipconfig → enter → now lookup your IP address and subnet mask.

Second create a zone in My Network Zones (Firewall → Advanced → Network Security policy). Choose Add → A New Network Zone → fill in a name like My local network → Apply. Now select My Local Network Zone → Add → A new address → choose An IP Address Mask → fill in your local IP something like 192.168.1.x usually and your subnet mask; usually 255.255.255.0 → Apply. Now check and see the new network defined. Exit using Apply.

Now we are going to use the Stealth Ports Wizard to make your local network a trusted network (Firewall → Common Tasks):
Choose “Define a new trusted network and stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → choose your local network zone from the drop down box at the bottom → Finish.

Now check your Global Rules and see your network added.

Ok, went thru all this, and I got “this zone has been already added to trusted zones list” and I still dont have a working connection with the xbox 360

Thanks Eric!

Hi, Just thought I would chip in here as I’m getting pretty much the same problem. Whenever I turn on (or off) the 360 I get a ‘New Private Network’ message even though I have it already setup on a trusted network which, until recently, worked perfectly. Now it is constantly blocked unless I turn off the firewall.

I don’t have a router so the xbox is connected to the PC and in turn to the internet.

I also get the new network detected dialog whenever the PC connects (or disconnects) to the internet.

I recently tried to upgrade to CIS v4 but it failed so reinstalled v3.14, could this have any connection?

Can you show a screenshot of your Global Rules? They are under Firewall → Advanced → Network Security Policy.

Here they are… thanks !


http://img94.imageshack.us/img94/9076/globalrules.jpg

What is the IP address of your computer?

When you created the Network zone what did you fill in for IP address and subnet mask?

Im pretty sure it’s

192.168.1.100
255.255.255.0

At least that’s what ipconfig is giving me for IP address and subnet mask

Can you post a screenshot of the rule for System from Applications Rules? It looks like the Stealth Ports Wizard did not add the changes to that rule.

no prob, but im not sure where to find that…

separate issue, i keep getting alerts for some of the same programs over and over from Sandbox
the alerts are for a PSPad text editor i use, and also vlc media player and something else
i always click keep inside the sandbox but even if i select the other option with “never ask me again” it keeps asking me anyway