~ New Private Network detected, odd.

hi, i read each of the threads here as best i could before posting with information regarding this pop up, but i am just a simple home user using one laptop, inexperienced, on XP and still learning this program. it says: 192.168.xxx.xx/255.xxx.xxx.x (no clue if i needed to write that or if thats a common knowledge IP standard.

i am not on a network. i am just me. i hope this isnt something scary, i had a lot of trojans at one point.

in some threads it said to ignore, some threads it said to do some places and do certain things, but i really do not know what to do. when i had problems with utorrent it took me 2 days to figure it out (still not sure if ive done that right), and im hoping i dont need to leave this wee pop up on my screen for 2 days. i would really like some assistance if anyone has some clarity.

i also have a screen shot of this, but didnt know how to post it or if that was needful.

thank you for helping, i hope i made sense.

Hi laoghaire

Welcome to the Comodo forum

If you are using Comodo Internet Security or CFP 3 you can open the program interface and click on Miscellaneous → settings. Under the general tab uncheck the box that says “automatically detect new private networks”. This should get rid of the pop up.

To post a screenshot click on “additional options” and browse for your shot.

Hope this has been a help to you.


Hi John, Thank you very much for replying, and the welcome. I enjoy reading all of the kind threads of support in this forum. I hope i am better protected now that i am using this service.

i appreciate your time. i didn’t know if this was a bad pop-up or not. i will post this screen shot first, hopefully it is alrite the way i diid this, if not, please someone let me know, i wasnt sure exactly how to do this.

I will then follow your instructions if there is no additional comments.

Thank you!


Just click on the close button
192.168.xxx.xxx is a local address Windows gives you if it cannot connect to your internet connection straight away.
I have had this sometimes if my connection to my router is slow connecting.
PS I presume you do not have a router?

It is normal pop-up. It just explain you that COMODO founded a new Network on some of your devices.
From this point you are able to do several things:

  1. Just click “Close”. COMODO will do NOTHING. All will work as usuall
  2. Give a name to this Network (any name) and click “Ok”. CIS (or CFP) will “learn” this network. It means in My Network Zones you will see this network with given name. From this time you will be able to use this Network in Creating/Modifing Rules (Select “Zone” ang choose there)
    Two options more to explain:
    “Do not automatically detect the new network” - it means right like it sounds =)
    “I would like to be fully…” - CIS (CFP) will create some Rules for this network (in/out for file sharing, printers, etc)

So, short overview:

  1. This NO BAD pop-up =)
  2. This designed only for you, and you may accept, or decline it
  3. You may read HELP of CIS (CFP) and look at this situation.

Hello Dennis Hello Exproff

Thank you both for such quick and very detailed replies, that was most gracious and helpful.

I will just close this, and no, i do not have a router. My connection does lag at times, so this does make a lot of sense.
I have a printer! but that is about as exciting as i get, but it is not even attached at the moment. I cannot imagine the excitement and chaos that will commence when that happens.

I am not sure if i should select “Do not automatically detect the new networks” this may be simple to you - but i had to read your explanations 4 times. honestly…

CIS= what? Canadian Intelligence Service? Cathartic Initiative Spies? i joke, but could you help link to me a place to read more what you mean? thank you very much for the great help!

CIS = Comodo Internet Security
No you do not have to untick the box just click the close button each time when you get a lag and nothing is saved.
Miscellaneous Tab/help/firewall task overview/common task/my network zones/note 5

Well, thats me blushing, re: CIS.

I closed it seven times. Thank you Dennis. I think that is me sorted. Cheers. ~

“Automatically Detect New Private Networks - Selecting this check box means that the firewall will automatically detect any new networks that the computer is connected to. Comodo recommends users to leave this option at its default, enabled setting.”
If you close this pop-up, you will not see it again untill NEW powering up a computer or changing IP on the device or getting IP on other device (device = Network Card or WiFi card etc.)
If you will give a name on this baloon and click OK, then in My Network Zones you will be able to see that named network. What it neede for and where to find it - see below explanations from official CIS help file =)

"Firewall Tasks > Common Tasks
My Network Zones

A computer network is a connection between computers through a cable or some type of wireless connection. It enables users to share information and devices between computers and other users within the network. Obviously, there are certain computer networks where you need to grant access to, including your home or work network. Conversely, there may be other networks where you want to restrict communication with - or even block entirely.

Comodo Firewall allows you to define ‘Network Zones’ and to specify the access privileges of these zones. A ‘Network Zone’ can consist of an individual machine (including a single home computer connected to internet) or a network of thousands of machines. to which access can be granted or denied.

Click on My Network Zone in Firewall Tasks > Common Tasks to open My Network Zone interface.

Note 1: Adding a zone to this area does not, in itself, define any permission levels or access rights to the zone. This area allows to define the zones so you can quickly assign such permissions in other areas of the firewall.

Note 2: A network zone can be designated as ‘Trusted’ and allowed access by using the ‘Stealth Ports Wizard’ (An example would be your home computer or network)

Note 3: A network zone can be designated as ‘Blocked’ and denied access by using the ‘My Blocked Network Zones’ interface. (An example would be a known spyware site)

Note 4: An application can be assigned specific access rights to and from a network zone when defining an Application Rule. Similarly, a custom Global Rule can be assigned to a network zone to all activity from a zone.

Note 5: By default, Comodo Firewall will automatically detect any new networks (LAN, Wireless etc). This can be disabled in the Miscellaneous - Settings area of the firewall.

To add a New Network Zone

Define a name for the zone.
Select the addresses to be included in this zone.
To Define a name for the zone

Click Add… button and select A New Network Zone… from the drop-down menu.

A dialog box appears, prompting you to specify new zone’s name.

Choose a name that accurately describes the network you are creating.

Click Apply to confirm your zone name.

This will add the name of your new zone to the My Network Zones list.

To Select the addresses to be included in this zone

Right click on the name of the new zone and select Add… from the menu.

The Add a New Address dialog allows you to specify an address by typing an IP address; an IP range; an IP address mask; a host name or a MAC address.

Click Apply to confirm your choice.

The new zone will now appear in the main list along with the addresses you assigned to it.

Once created, a network zone can be:

Quickly called as ‘Zone’ when creating or modifying a network policy

Quickly called and designated as a trusted zone from the ‘Stealth Ports Wizard’ interface

Quickly called and designated as a blocked zone from the ‘My Blocked Network Zones’ interface
To edit the name of an existing Network Zone

Select the name of the zone in the list (e.g. home) and select Edit… to bring up the naming dialog.

To add more addresses to an existing Network Zone

Right click on the zone name and click Add… or select the zone name, click the Add… button on the right and select A New Address… from the drop-down menu.

To modify or change the existing address in a zone

Right click on the address (not the zone name) and select Edit… or select the actual address (not the zone name) and click the Edit… button on the right.

Copyright © 2005 - 2008 COMODO. ® All Rights Reserved"

If this happens every time you can untick the box.
You only need comodo to find new networks if you change you connection anytime.
No need to blush I thought they were very good suggestions :slight_smile:
Best Wishes

Sorry to jump in guys but,

192.168.100 etc is not the windows default IP.

Windows defaults to 169.254.etc …

So from the screenshot the OP is connected to a router.
As it is a laptop this might be connecting wirelessly without the OP’s knowledge.

or does the OP have a modem/router not realizing?

This needs to be sorted, Before deciding which network to join or trust.
And then do all the firewall set up stuff accordingly.

The implications of windows automatically joining any unsecured WiFi network,
and a different one on each boot randomly is huge wouldn’t you say?

Like I said sorry for jumping in but he IP address thing jumped out at me.

well im really confused now.

i have a wireless network card, its: “disabled, firewalled” i hope that is right.

re: box - it has not come back and i didnt not tick it - it was default unticked.

i am only on a modem, but maybe this modem has a router inside of it and i do not know? how would i check? i read online some modems have both.

i really appreciate all the effort and comments.

i really i wish i knew what i was reading in the long post about the new private networks, it was great of you to post it exproff, ill keep trying!

but my main confusion is a few of my websites do not work at all now. yahoo wont load at all, flickr only loads half way( either in full text or white box with red square), and photo bucket took too long. i thought it was my connection, but a lot of my other websites are fine. it must be a change of some odd setting.

re: IP numbers, should i call my provider? or could i possibly done something with a firewall setting? should i post all of this elsewhere, as this is leading off into a new direction – or does this still go with the original topic?

again - cheers for each of your assistance. i am going to re-read them all now. yay for all the great help here.

Hi laoghaire,

Sorry to have caused you some alarm.
I was concerned because of the IP address not matching the story.

“i have a wireless network card, its: “disabled, firewalled” i hope that is right.”
beautiful, yes that is right. Disabled unless you knowingly intend to use it.

“re: box - it has not come back and i didnt not tick it - it was default unticked.”
Mine is ticked, but it makes no difference unless you are moving around or reset your
router etc… Like the good folks have explained.Ticked is recommended though.

“i am only on a modem, but maybe this modem has a router inside of it and i do not know? how would i check?”
You are connected to a modem/router.
If you only had modem you would have a Public IP Address. Yours is Private range.

EDIT: My supposition above was wrong, Here is why. The modem if it has no WAN connection will give 1 private IP for diagnostic purposes. End edit for factual correctness.

So yeah, You are good to go!

Your other browser page load issues etc.
Maybe start a new thread, mention which browser as much pertinent info as you can.
Could be temporary or any number of things.


Thanks for jumping in sometime since I had a alert I had forgotten should have done a search first. :-[

Very sorry for supplying the wrong info could you please post make and model of your modem.
To check if your wireless is disabled right click on icon in task bar click on Open network connections.
It should look like screenshot below.
EDIT When you say this(wireless network card, its: “disabled, firewalled”) have you Windows firewall running?

[attachment deleted by admin]

Bad Frogger, Thank you very much for the added clarification. I think its great you cleared up my confusion… It was nice of you to spend some time doing so and cheers for the advice on the box and router. i will keep watching.

re: other websites not working, it must have been a selective one day thing, as they are working fine now.

Dennis2, my modem router is: Motorola sb5102 Cable modem

Here are my local connections. thank you for being so concise as to what it is you require. please let me know if there is anything i have missed or anything else i can do. everyone is so very helpful and gracious.

Edit: re: Dennis, i searched online via google and found instructions and located that i am indeed running Windows firewall. what would you like me to do?

[attachment deleted by admin]

Thanks for the link for your modem :slight_smile:
I have read the user guide.
It is just a modem if you want to connect more than one computer you need another box if you provider allows.
Any further problems please post.
Sorry again for making mistake reguarding the IP’s :-[
Best Wishes

Sorry missed your edit you should not really have two firewalls running CIS should disable it but does not at this time.

hi Dennis,

i followed online instructions regarding windows firewall and disabled it. this is how it appears now:

thank you for your help!

p.s.any theory as to why do i have two connections? odd.

[attachment deleted by admin]

2 connections because:

  1. Is the LAN connection (network cable plugged to your network device)
  2. Firewire IEEE 1394.
    On My laptop I have same 2 CONNECTED connections =)

Firewire, well – i learned something new today. i didn’t know i had that. thank you… Seems this Comodo place will be teaching me quite a bit –

Cheers everyone. i read more than i post…

(:s*) (:s*) (:s*)