new LW problem *sigh*

Hi! … again :frowning: :-[
Yep it’s true, I have another limewire Direct connect issued problem.
And this time I KNOW I have not done anything with the settings since last time.(not that this info matters because this is nothing that just happened, this was the case since I got my DC back to working business)
My problem is: I can’t download stuff from anyone I direct connect to!
I can upload stuff just fine, and send to my friends, but when I want to download something from them, I see their list of files but the files on the list is broken and I can’t download anything :frowning:

I was thinking it has something to do with CPF blocking some IP’s but I’m not sure.
Could it be that If I just allow certain IP addy’s, (the DC number is based on your IP but adds 4 digits or replaces them… I’m not sure…) maybe it’s as simple as creating a network rule to add my friends IP?
But then I’d need to do this every time I want to download from someone… :-
Is there any other way perhaps?

Any help is appreciated. Thanks!

Hi novis

If CFP is blocking something then there should be corresponding block entries in CFPs Log (Activity tab). Also you can quickly confirm if CFP is causing this problem by temporarily setting CFPs Security Level to Allow All on the systray icon. At this setting CFP will not block anything.

Hi and thanks for a great forum and a fast reply (once again) :slight_smile: (R)
I just checked my activity log and I have loads of outbound and inbound medium severity checks there caused by the network monitor. I have not tried to connect to my friend for a while now since it did not work, so I don’t know if that would make an entry but I guess it will. Problem will be to see what entry it would be exactly, in the long log list…

I would believe it’s the firewall since I have no blocked IP’s typed into LW that i know of(and before I installed CPF I could download through DC just fine with my old FW).
But, could I set it to allow all for a while and connect to my friend and even if this would take a few minutes, say I’m in that state fro about 10 minutes, would it not be any great harm against my computer?
The weird thing is that it seems to work out from me but not in to me.
But I can download stuff just fine, It’s this direct connect feature that’s the tricky and sensitive thing, apparently. :frowning:

That makes sense… when receiving a connection from your friend, then it is likely to be viewed as an unsolicited connection attempt (ie. something that your system didn’t ask for). All that I can recommend is that the next time you hook up with your friend & it doesn’t work… then you immediately check CFPs Log to see what was rejected. Remember your friend can give you their IP number & this should make it easier to spot. You can also change the Log display to only show “Todays” events (actually the last 24 hours). Failing all that, you can always export your Log to an HTML file & then cut ‘n’ paste the results here to get assistance (remember to mask any private IP addresses).

OK thanks! I’ll give these things a try and get back with the result.

Hi. OK i just tested the allow all option. But after doing so with an unsuccessful attempt, I just remembered that with my previous LW problem when we tried to do that it didn’t work ether(which lead me to believe the problem was LW related, which it was not in the end anyway and it was CPF that was blocking a port I needed to open, LOL) so I’m not so surprised it didn’t work this time ether. Even if the problem’s different.

Anyway my log is already set for just today and it’s full with entries, about 5 adding every minute 88) all just saying inbound/outbound connection problem and most of them referring to a rule 7 problem…

A dummie question, but what exactly does inbound policy violation really mean? Is that something going IN to my computer or is it some internal “problem” inside my computer? (I’m not English speaking by nature and sometimes things get a bit too technical)

But now it seems, seval minutes later, that I found the entry with my friends IP. I exported a log and I can send it if you want, but I’ll type out the problem description here first:

Description: Ibound Policy Violation(Access Denied, IP = XXXXXXXXXX, port 9541)
Protocol: UDP Incoming
Reason:Network Control Rule ID=7

hmm… this repeat of the port nr 9541 could this mean something? Maybe I could add some rule to that port? If so what’s the best way to go about doing that? Just adding it separated by comma or something in the already existing network rule for LW or creating a new rule?

Yes, 9541 is the port number. CFP isn’t expecting contact on that port from that IP. So, its blocked it. Your LW rules probably specify a port number & you need to either get your friend to change his to port number to whatever your LW rules say or you need to either modify the existing LW rule to include this port number or add another LW inbound rule for that IP & port number 9541.