new laptop will not let me load comoco firewall platform not supported?

trying to load comodo firewall on new laptop error message says platform not supported

Hey and warm welcome to comodo forums!

Could you tell us what OS you have. what security software did you have before.

Regards,
Valentin N

OS windows 7 new laptop hp will not allow comodo firewall (platform not supported)?

do you know which version? I think that’s where the problem lies.

Regards,
Valentin N

Do you have 64bit OS or 32Bit OS, there is a chance you have the wrong executable for CIS, and that would show such a error.

See here on how to figure out if a OS is 32bit or 64bit:

You can select the correct version of CIS after you find out, here:
https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-531746221216-released-updated-to-531767571236-t67084.0.html;msg472867#msg472867

Or Simply Download the “Universal Installer”

http://download.comodo.com/cis/download/installs/installer_data/binaries/cispremium_installer.exe

Thanks

Jake