New installation - No internet or local network [Resolved]

I’ve already installed Comodo on one PC with no problems!
Just installed it on the second machine, and whenever Comodo is installed, the network adapter shows as “limited or no connectivity”. Switching off Comodo doesn’t help, but uninstalling it restores everything to normal!
I’m also getting a message about “terminal services” from Comodo - which is odd, because Terminal Services are disabled on both machines.
One thing I’ve spotted - the supposed IP address for the second machine, as shown in Comodo, is not correct - it’s showing a number in the 169. range, whereas the router is set to 192 x range. Could this be the problem? If so, any ideas how to fix it please?

Just tried uninstalling again - the PC is assigned an IP address in the 192. range, and everything is fine. Re-install Comodo, the IP address is in the 169 range, there’s “limited or no connectivity”.
Even tried reboooting the router, but no joy!

Thanks

Nige,

The 169.x.x.x IP address is assigned by Windows and generally means that there was no connection available at the time of assignment.

A few things…

After installing CFP, did you reboot?

Prior to installing, did you completely disable/turn off any and all other active security software (AV, antispy, HIPS, etc)?

In CFP, go to Security/Advanced/Advanced Attack Detection/Miscellaneous. Make sure the box, “block all outgoing connections while booting” is not checked. If it is checked, uncheck it, click OK and reboot.

LM

Thanks for the reply Little Mac!

  1. Yes - rebooted mutliple times
  2. Uninstalled Zone Alarm - searched for any za related files and deleted them. Scoured the registry for any reference to ZA and deleted.
  3. Checked the settings option (it was unchecked already) - rebooted - Comode initialzed - IP address 168.xxxx and no joy!

When you installed CFP on that 2nd machine, did you have any AV or antispyware running?

What is the physical configuration of the machines and internet connection? Are they connected to the router, are you using ICS, etc… ?

LM

Definately sounds like a dhcp problem. For testing purposes, you could try setting a static ip (i.e 192.x.x.x) on your computer and see whether that works. If that does the trick, change back to dhcp and disable (turn off) network monitor. Also, check your logs for anything being blocked.

:slight_smile:

I had NOD32 running when I installed on the 2nd machine (yes, I know… schoolboy error). I uninstalled Comodo, then NOD32 and re-installed Comodo thinking that may solve it.

The computer is connected to the router.
Usually, each computer can see the other (they share a printer and some files).

Thanks

Have you defined a Zone to encompass the two computers and your router?

Once you do that, use that Zone to establish a Trusted Network, whereby all traffic can move unimpeded between those three points.

That may help. Both those tasks are found under Security/Tasks in CFP.

LM

It looks like the Network monitor is blocking the router, but switiching the NM off has no effect.
I think I’ve tried defining a zone - but Comodo keeps reverting to the 169.xx range.

I’ll have another go…

If it were the NM, switching it off should resolve the issue…

Will you go to Activity/Logs and see what you’ve got there? You can right-click an entry, select, “Export to HTML.” Save & Reopen the file. Copy the recent entries (around the time of the failure) to the clipboard, and Paste them as text into your post here.

Also, open NetMon to full-screen. Capture & save the screenshot as a jpg, gif, or png. Attach to your post under Additional Options.

LM

Hmmm
It’s getting a bit silly now!

  1. Network monitor is off
  2. Trusted Zone in the 192.xx range defined.
  3. Trusted Network in the 192 range defined.

Log still shows that the router is being blocked incoming.

Just tried manually assigning an IP address (the one that the router had assigned, according to the settings page from the other computer), and the machine thinks its connected, according to network connections, but still no internet!!

Nige,

Will you post the Logs and NetMon screenshot as above? This will help identify what is getting blocked, where, how, etc. That way we can resolve it.

You can mask out your personal IP from either the screenshot or the logs (it probably will only show in the logs, where you can use “x” to mask the numbers).

TNX,

LM

Erm…
Not quite such an easy task to upload monitor logs and such when the computer isn’t connected to either the network or the internet!
The log is empty (just tried to re-install). The ethernet adapter shows as connected (since I forced the IP address), but it’s going nowhere.
I’m beginning to think that ZA wasn’t so bad afer all!

And here’s the killer - Just tried with Comodo set to Allow All.
This means allow all connections, I think?
Well, no. Comodo is, in effect, silently blocking something, because as soon as I uninstall it, everything’s fine!
I give up - I use Comodo on my machine and think it’s pretty good, even though it chatters away like mad. This second machine is my wife’s - even if I can spend more time getting Comodo to work, it will drive her bananas!
Thanks for all your help, but I think that Comodo just isn’t compatible with something on this second machine. I’m going to have to find an alternative!

Setting to allow all will even override an emergency mode lock. Since this hasn’t worked for you, I conclude that something conflicted on install; that’s the only time I’ve seen strange responses like this.

You may have uninstalled & reinstalled with Nod32 off; it probably would been good to follow that procedure again, and run a registry cleaner before reinstalling, to clean out the “gunk.”

However, I also understand, it being your wife’s machine, if you want something that will require no intervention or interaction at all. Unfortunately, that means the same amount of security, as well… :frowning:

If you want to keep plugging at it, I’m happy to help. It’s a little bit longer, perhaps, but you can always transcribe the log files from her computer, or save it on a disk there, put it on your computer and upload it. There are ways around that problem… :wink:

LM

Thanks for the offer!
I’ve just searched the registry for all NOD32 and Comodo references and deleted those that I could. All NOD32 entries went without a hitch, but there are Comodo entries in varous places that can’t be deleted “Comodo Application Agent” and “Comodo Firewall Agent” which are locked for deletion.
So, I deleted the registry entries, then rebooted and then installed a fresh download of Comodo, then rebooted.
PC starts up - Comodo iniitializes - all modules are on - there’s no entries at all in the log. Network Connections shows “limited or no connectivity”.
Network Monitor screen shows the 5 default rules that Comodo creates automatically.
The main screen shows that Comodo thinks the IP address is in the 69. range.
I add the 192 range to the trusted networks and try a “Repair” on the network connection . At this point, NM log show a Medium - Access Denied - IP = 192.xxx Port = nbdgram (138) - Protocol UDP Incoming.

My apologies, Nige; I should’ve given more detailed instructions regarding uninstalling and cleaning out, especially in regards to the FW. Your listing of those two entries reminded me of my oversight. Given the situation, I think it would be worthwhile; if the initial install was corrupted, leaving these in place will mean they stay the same…

We’ll do a step-by-step to uninstall the FW completely. You can leave Nod alone at this point.

  1. Right-click systray icon for CFP, choose Exit. This will shut down the GUI.
  2. Go to Start/Run, type in “services.msc”; find the entry for Comodo Application Agent, and set the startup type to Disabled.
  3. Go to Start/Run, type in “devmgmt.msc”; then View/Show Hidden Devices; scroll down to Non Plug N Play Drivers, and find entries for Comodo Application Engine, Comodo Network Engine. Change them to Disabled.
  4. Go to Start/Run, type in “msconfig”; go to the Startup tab, find the entry for Comodo Firewall Pro and uncheck the box. Select Apply, then Close. Skip the reboot for now.
  5. Uninstall Comodo FW. Reboot.
  6. Go back to step #3 above. If they are still showing, select Uninstall. Reboot if you have to Uninstall.
  7. Run registry cleaner; reboot.

Now you should be good to go to reinstall the firewall. Make sure to completely disable Nod32 (double-check w/Task Manager to make sure it doesn’t have any processes left running) before installing CFP.

LM

(:CLP)
My apologies to you too Little Mac - Tried your steps, and all was ok, network connected, but CF wasn’t running. So, I enabled the 2 entries in Device Manager and rebooted and everything stopped.
So, I started again, and while I was searching the registry I noticed an entry that prompted me to remember that I did in fact have another firewall! I haven’t used it for years - Part of SystemSuite (which was rubbish btw). I had disabled it in the SS control panel, and I’d had no problems with ZA - so this time I uninstalled it, swept the registry again, rebooted, re-enabled Comodo devices and…
YAY!
All fixed. Thanks very much!

Nige

Aha! Glad you spotted that; otherwise we could have been running in circles for a long time…

I’ll go ahead and mark the topic as Resolved for other users’ benefit, and close it. If you need it reopened, just PM myself or another Moderator; we’ll be happy to reopen it for you.

LM