New install- - Windows Defender update fails.

This morning I removed my nVidia HW FW and installed CFP. All went without a hitch. My boot time increased only about 10 seconds (64 seconds from splash to ready to go, prefetch disabled). CFP plays well with avast! (including WebShield) and the other apps so far. The only problem I have discovered so far is that I cannot update Windows Defender. I get a ‘can’t check for updates’ error x80072f78. I also get this error during a scan on Windows Update. I see other posts on WU not working and tried the ‘Permanently turn off Def+’ fix suggested but received the same error from both. Please let me know if there something else to try.
Overall, I am VERY impressed with CFP - great job!
BTW, after I turned off Def+, I could not find status that said it was off. Where do I find this? - Summary said all systems running.
The install video, although very well done, is not very useful on ver 3.0.
I took the default settings in all cases.
I am running Win XP Pro x64 Ed.
Thanks for any suggestions on the update problems…John

By following the link in the MS error message I have found how to update Windows Defender. will lead to the MS site for manually updating the WD definitions.

the only time i had had an isue with defender getting it’s updates (with an older CFP version) was when i mistakenly had a rule in the program list set where system or svchost was being blocked.

have you checked your application rules for blocked windows components?

Thanks, m0ng0d for your reply.
I will check my settings but I took all the defaults when I installed and expect these are not blocked.
I am on a different machine today (without CFP) and also cannot update WD (different code - 80072ee2). So now I suspect that MS has an update problem. I also tried to do a custom scan on the Win Update site and it just hung there. This may explain the problem on my CFP machine with WU.
Thanks again…John

Both WU and Defender Update work on my CFP free machine. I guess there was a temporary error. I am back on my machine with CFP and have the same error with WU and WD Update.
Sorry for the bad news…John

This problem is resolved for me. It turned out to be a HW problem. I have an Epox MB with nVidia nForce4 Ultra chip set. The chip set has a NIC with a HW firewall which I removed to install the CFP. When I first used the machine, I could not upload attachments on e-mails. This turned out to be a CRC offload problem. I turned off CRC offload via the FW and all was well. When I removed the FW I guess the CRC offload became active again and was damaging the data I was sending out. I turned off CRC offload via the Device Manager but that did not help - surprised me! Fortunately I had a PCI NIC which corrected the problem when I used it instead of the nVidia. Both WU and WD updates work for me.
Good luck on your hunting…John