new (I think) V4 installer problem on Windows 7 x64 signature verification fail

I downloaded and ran the installer 4 times and this message “pops under” my other windows:

Image signature verification failed. Installer will now close.

From where did you download the installer?, the same way I downloaded previous releases…

I cleared my cache and downloaded again today and the result was the same error.

Are you sure it is the 64 bits version you downloaded?

Most of the time I am sure that I get x64 compatible software, but this time, I searched for the x64 version but couldn’t find it. I assumed that the installer would detect that 64 bit was needed and download the correct version automatically.

So where do I find the x64 installer?

Ha! Got it.

Apparently, my FireFox isn’t downloading the installer correctly. I don’t know why 'cause it downloads everything else correctly. But anyway, Internet Explorer got it just fine.

I thought that error was fixed by now. Well, apparently not. :-\

I will move this to the Report Comodo Forum / Web Site Issues board and will edit the title accordingly.

Oops, maybe that wasn’t it. I just compared the two files, one downloaded with FF and the other DL’d with IE, and they were identical.

Maybe it was the fact that I still had the old version installed when I ran the installer.

I don’t know…

I jumped to a conclusion here as well. I assume now you downloaded the online installer with 2,7 MB size. Is that correct.

Usually the installer would uninstall the previous version. Did you get a notification to uninstall the previous version?

Maybe the off-line installer would help?

Yes, my installer was 2.7MB, and yes, the offline installer would have been a good way too, but No, I didn’t get a prompt to uninstall a previous version. That error message was all I got.

em, I find that this question is quite confusing ???
I thought that now there is no 32 and 64 bit versions and the the installer will download the write version.
What do I have installed now ??? 88)

The message “Image signature verification failed. Installer will now close.” was that generated by the online installer?

Did the off line installer fix the problem for you?

Sorry for the confusion. I jumped to the conclusion that an old problem had reoccurred where the user would get the wrong version from the website. That’s not the case here. As far as I know you got the right version from the online installer; I haven’t seen any people reporting an error with that.

I didn’t use the offline installer.

I uninstalled the previous version and rebooted, then used internet explorer to download an identical copy of the installer and and chose “open” or “run” or whatever from the “download complete” message.

Later I compared the files downloaded by FireFox and IE and determined that they were identical. Apparently the problem was just running the installer while the previous version was still installed. My gut says that it may be due to either a corrupted previous installation, or maybe Defense+ made it incompatible like it has caused problems with several other pieces of software in the past for me.

I just downloaded the latest 64bit standalone installer from the Comodo website and tried to install it on virtual machine. This failed, because the installer gave me the message “Image signature verification failed. Installer will now close.”

Searching for a solution I found out that you will get this mesage when you try to install from a shared folder. Copy the installer to a “native” VM folder, run it from there and the error is gone.

Same problem here, I got this same message from “cisfree_installer.exe” (web-installer) and “cisfree_installer_x64” (offline 64bit instaler).

It was located at a mount-point dir: I have a second harddisk mounted as C:\Downloads, and installer popup this error if I try to run it from there.
So for the “solution” I moved it to another folder.

Using Windows 7 x64

I tried to install from public directory located on our server, both x64 and x32 offline versions found here:
both gave me this error message. path was in UNC notation like this: \server\public\security\cisfree_installer_x64.exe
then I copied it to local hard drive, and voila! it works.
To figure it out, I mapped \server\public to Z:\ and then executed the setup via the mapped drive Z:\security\cisfree_installer_x64.exe but same error-message. So UNC is not the problem but network server is (I have full access rights there)

I failed to run cisfree_installer_x64.exe. It gave the information “Image signature verification failed”.


  1. OS: Win 7, x64, Japanese Ver.(Just has been installed)

cisfree_installer_x64.exe was downloaded with Firefox, IE, IE x64 to a local driver,
however “Image signature verification failed” was displayed as it was executed.

The same thing happened to cisfree_installer.exe and cfwfree_installer_x64.

  1. OS: Win 7, x86, Japanese Ver.

a. cisfree_installer_x64.exe was downloaded with IE, the installer worked and the image signature
verification was executed normally. Thus it concluded that the installer was downloaded correctly.

b. Then cisfree_installer_x64.exe was copied to the PC (OS: Win 7, x64, Japanese Ver.). However
“Image signature verification failed” was displayed as it was run.

I was really confused. Bug in cisfree_installer_x64.exe?

Somebody came up with the following. He started the installer that the online installer put in the download folder. Does that do the trick for any of you?

I am getting the same problem on a 32 bit machine with the offline 32 bit installer. I have my downloads on a separate drive (drive f) which is a USB external drive. I tried the solution of copying to my desktop and voila it works. I think the installer has a bug.