New Comodo update screws up my computer!

Help! I updated to the new Comodo version (the one with widget and stuff) and now my computer is acting strange. Since the update:

*I can’t access the Gadget menu (right clicking on desktop and clicking Gadgets), though sidebar.exe loads and all gadgets except one is still working
*One of my Gadgets is not showing, the Drives Meter by
*Because I felt things had gone wrong I tried System Restore, but after the computer loading again it said that it couldn’t system restore
*Can’t shut down or restart my computer because at “Logging you out”, it stays there and won’t continue shutdown. I have to press the button and hold it until it shuts down
*Can’t end cmd.exe or any other comodo process in the task bar. It just says “Access denied”

What the hell, Comodo? What has the update done to my computer? Is there some kind of setting that has been changed that is blocking some functions?

I chose to not install the toolbar or the strange program (it had a Dog as a logo) it wanted me to install.

I use windows 7 with Comodo and Avast.

Could be this bug:

Solved this by uninstalling Comodo and instead installing ZoneAlarm. Ironic, since some years ago I changed from ZoneAlarm to Comodo because ZoneAlarm ■■■■■■■ up my computer then.

My computer behaved strangely even when I shut HIPS down.