New Applications not blocked by Default...annoying

hi guys!

I am quite annoyed about this.
Even when I set the Firewall in “training mode” it doesn’t produce any pop-ups to ask me about anything.
(Do not show pop-ups is unchecked everywhere I see it!)
I expected that it would block all unknow access and ask me.
Especially annoying when I install new software.
I need it to intercept all network access and ask me to either block or allow it.
It just never does.
So I always have to use the “block all” option.

How can I get this Firewall to actually go into “training mode” aka ASK me for every application trying to access the web…

Training mode DOES NOT ask you for permission when an unrecognized application or safe application request network access, it will automatically learn and allow the access requested by the application. What you want is to set the firewall to Custom Rulset to generate alerts for any application that requests network access, if you only want to get alerts for unknown applications, then set the firewall to safe mode.

thank you.
I always thought “custom” means I need to go edit the rules directly or something.
These ruleset names confuzed me. I really expected Training would do what Custom does.

maybe you should rename the rulesets.
Training → Auto Decision (based on what? existing rulesets by Comodo?!?)
Custom → Ask Always
Safe → Ask if Unknown

Also, what is the difference in these Global Comodo Settings?:
Internet Security
Proactive Security
Firewall Security