networking vista and xp

i am having some difficulties networking a vista home premium laptop and an xp home laptop. vista laptop is wireless, xp laptop is wired. both connected to a dlink router. both have internet connections.

here’s what i have done:
1 same workgroup on both
2 LLTD for xp laptop
3 Can see xp laptop on vista network map but cant connect get “error code 0x80070035”
4 cant connect to workgroup with xp laptop “workgroup is not accessible…network path not found”
5 comodo firewall/my network zones - added a new zone with IP range is the same on both computers
6 stealthed ports for said network zone on both computers
7 have shared files ready

what am i doing wrong or what am i missing?


is it that difficult to set up a proper network with comodo?

just to add from what i have already noted:
8. with firewalls on both computers “disabled” i can see and have access to both. that is the only setting that works.

Are there any relevant entries in the Firewall logs? This should tell us what is being blocked.

hey hey hey! good to hear from someone!

here is what i see for my laptop (VISTA):

  1. a lot of blocks for UDP coming from the router IP address by svchost.exe always on same source port
  2. a lot of blocks for TCP coming from desktop computer IP address by “system” on various ports

these are the only 2 actions blocked for today since i turned my computer on. both actions seem to get blocked multiple times a minute.

here is what i see for my desktop (XP):

  1. azureus application being blocked for TCP and UDP. sources IP and source ports are various(obviously).

multiple instances blocked usually seconds apart. i’m not too suprised by this b/c it is torrenting.

on my xp computer i can see the laptop in view workgroup computers but can not access it. “laptop-pc is not accessible. you might not have permission to use this network resource…the network path was not found.”

on my vista laptop i can see the xp computer on the network map. now when i go to network folder i cant see xp computer but i can see azureus (which i only have installed on xp computer)

any thoughts, panic?

First things first…

  1. Turn on logging for all rules
  2. Clear all logs
  3. Reboot
    3b. This particularly applies to any torrent software - let’s not muddy the waters unnecessarily.
  4. Try and access the PCs on your LAN several times
  5. Turn off logging for all rules except any BOCK rules you have set up
  6. Export the logs
  7. Post a transcript of any relevant details back here.

N.B. “Relevant details” means protocol, direction, source IP, destination IP, source port, destination port. It does NOT mean “same source port”. Please be specific.

Ewen :slight_smile:

i did what you said, i think. on both computers, i couldnt find how to turn on logging but i went to log viewer and removed current filter, then i cleared all logs for both firewall and defense+, rebooted, tried to access the each computer from the other one (to no avail), exported new logs and added it as an attachment.

only my laptop (vista) had new logs. my desktop (xp) didnt have anything to report.

[attachment deleted by admin]

A friend with Vista had that same problem and error code last week and finaly got it working. I’m unable to get him on the phone right now to find out what he did to finally fix it. He was not using Comodo firewall.

If you do a search for that error code you will see a lot of people having the same difficulty. I’ll keep trying to contact him and post back as soon as possible.


it’s been a few days. any thoughts, panic?

did you get my attachment?

I think you have accidentally blocked SVCHOST.EXE and the Windows System calls, as shown in the logs. Go through your application policies and modify SVCHOST. EXE from BLOCK to ALLOW and do the same for windows Operating System (maybe be shown as WOS or just SYSTEM).

Hope this helps,
Ewen :slight_smile:

that worked great!! thanks a bunch, panic. how come it’s always something so simple? i am very appreciative of your expertise. i can now see everything and access everything shared. however…i’m not sure if anyone will be able to answer this question or if i should find some other place to get help. here’s my new challenge:

on both computers i have shared files over the network(music, documents, videos, etc). i can open all the music/documents files, i can open most of video files. some videos open just fine while others say file not found. i am using vlc player to open the files. when i go to open they say “unable to open …”. i can take that same file and play it on the computer in which it is stored(desktop) and i can transfer it via thumbdrive to my laptop and it will play just fine, too. i have the same codecs installed on both computers using the same video app (vlc) but i cant play the video over the network. videos that i can play i am able to copy and paste on to my laptop over the network. videos that i cant play i am not allowed (i do not have permission) to copy and paste. any thoughts?