Network zone “169” (again)

Greeting all,

The questions and issues with Firewall detecting the “zone 169” were asked and reported many times in the forum. Just the search for “169.” will give many results.

It is understandable:

  • what it means;
  • the zone, if created, can be safely deleted;
  • it may happen during Reboot or when the System wakes up (stand by / hibernation);
  • etc.

What remains the problem through many versions of Firewall (old standalones included) are
as following:

1) Firewall does not hold the option “do not automatically the detect network zone”
The said zone can be detected spontaneously any time. I have to admit that it is not a frequent event and in my case it’s happenning mainly during Rebooting usually when PC was switched Off.

2) Despite checking the box “do not…” again - the “169-zone” will be created straight away;

The result is “Limited or no connectivity;

3) The “169-zone” has to be Removed and computer must be Rebooted in order to get connectivity

I hope that developers will review the issue and find the solution.

My regards

Windows will hand out an IP address in the 169 range when it can’‘t find a network. This part is out of Comodo’'s hands.

In this situation where a Windows doesn’t see a network you may want to make an ad hoc connection to another computer. Therefore it is a good thing CIS defines the network. On the other hand when your computer is permanently connected to a LAN/fast internet connection getting an address in the 169 range usually means trouble.

As to point 3. You can safely delete the zone but as far as I can tell it is not a law you need to reboot the computer to get connectivity again. Rebooting may surely help but other methods may work as well; think restoring the network connection by Windows.

Do a google on “APIPA” (Automatic Private IP address). Windows will automatically allocate an address in the 169.254.X.X range if it doesn’t have a static address or it can’t find a DHCP server. Some PDAs will also use a 169.254.X.X address for synchronising.

169.254 isn’t a bad thing.

Ewen :slight_smile:

Hi Guys,

Thanks a lot for the response.

As I wrote the basics about “169-Zone” is understandable.

169.254 isn't a bad thing.
thanks for reassurance Ewen :)

I will just point few things

1) It happens rarely
2) I have static address
3)

… think restoring the network connection by Windows
that never worked in my case
4)
… This part is out of Comodo’'s hands
Ok then…
At the same time that still leads to repeated questions by users

I will put it this way.
a) Is it possible to have a simple explanation specifically for this case somewhere on that “Green Screen”, kinda a link to help file section or something, which is added to the screen only when “169” detected
b) The appearance of the screen with Cleared checkbox “do not detect zone automatically” when it was set previously checked is still confusing and ambiguous.
Does it mean that users have to “re-tick” the box because of this event?
As I see it (I better be wrong) that will reset previous user’s choice if user will not take care and check it back immediately.
The question is: if the appearance of the dialog for “169-zone” is “out of hand” is it possible that it is displayed with options as those were set before, or that is out of control as well?

Thank you again
Cheers

a) That sounds lke a good idea to me. It may help to reduce confusion as you intended.
b) I didn’t mean to say the dialogue box of the 169 was out of hand. Windows creating the 169 zone is out of hand. I can see the need tio override the setting " do not detect zone automatically" but it needs better explanation at some place.

Thank you for reply EricJH,

I’m glad that you found the “a)” idea helpful :slight_smile:
As for b) I do understand that you were talking about the event itself of detecting/creating the 169-zone
My question was really about the settings only in the dialogue. I even think that the appearance of the dialogue is correct - the silent zone creation would be questionable action.
The final question regarding “I can see the need tio override the setting " do not detect zone automatically”

Are you saying that in such situation it is necessary to present the dialogue “as is” and re-ask users to reset the option again explicitly?

That is not arguing. If there are reasons for that - it is fine with me especially if developers will add (I hope ) that explanation as discussed.

Cheers!

May be they could change the setting to “do not detect zone automatically unless it in the 169 range”. Its just a thought.