Network Security Policy - Application Blocking [Resolved]

I have a home network as follows
Desktop PC with 2 NICs, one wireless, one wired.
1 x NAS box
1 x router / switch
1 x gigabit switch

All wired devices connected to the gigabit switch. Gigabit switch has a wired connection to the router.
I have a backup application which runs periodically to backup My Docs to the NAS box. I want to route all backup traffic through the wired NIC.

In CPF 3 I have set 2 zones - one containing wireless NIC, one with wired NIC. I have then tried setting Network Security Policy to block zone containing wireless NIC for the backup app. So far this has not worked, some traffic always go via the wireless. I have also tried blocking by IP address.

My latest try is as follows

Source Address

Action : Block
Protocol : IP
Direction : Out
Single IP : wireless lan address

Destination Address

As above

I have ticked the box ‘Log as a firewall event …’. I never get an entry here.

Can anyone shed any light on this please?


Welcome to the forums, Colinr384

Is there anything in the logs? I’m curious if there is any other kind of traffic showing in your logs, as opposed to just not seeing log data for this problem.

I probably need to understand more about your CFP configuration. There is a Config Reporting Script that will dump your setup in readable words that you can post here. The script is available in the sticky topic at the top of the forum page.

I’m suspecting there is some kind of broadcast traffic, or an address overlap, that your rules are letting thru. But that’s just me making a guess, with nothing to support that guess.

Hi grue155
Thanks for the welcome. I have run the Config Reporting Script and from the output have solved the problem. Not sure of the technical explanation but by adding the rule under System rather than the app that was generating the traffic, blocking seems to be working. Got the clue by checking what Active Connections was showing along with the CRS output.

Thanks for your help

I’m glad to see that you’ve solved the problem. I’ll close this topic, and mark it as resolved. If you need it reopened, just send a PM to any of the moderators.