Network Protection turned off by itself

We have been using Comodo for 2+ months with no problem. My husband was surfing the net last night and suddenly a message popped up saying the network protection was off and that reinstallation might resolve the problem. He looked first at the Comodo screen, it showed three of four statuses as green. For the network one, he tried to turn it on but can’t select it.
He logged off and then back on again. When the Comodo icon appeared, mouse over message said ‘initializing’ but never got a good status. When he opened up Comodo, all 4 statuses were red.
He checked the Microsoft firewall and it was on so he uninstalled Commodo and reinstalled from the copy we already had in the downloads folder. When the PC rebooted, Comodo showed all good statuses but now Microsoft doesn’t recognize that we have a firewall. He lauched Firefox and also Outlook and Comodo popped up its normal message when it sees a new application trying to access the internet. He selected allow and both worked. What is going on? We have NOT install any new programs. How can we get Microsoft to recognize that we have a firewall. How can we prevent this from happening again.

Our system is XP Pro SP2. We have NOD32 v2.70.39, Ad-Ware 2007 v0026, Sypbot v1.4.

G’day novice973 and welcome to the forums.

Getting the windows Security Centre to acknowledge a security is relatively easy. If you have a look at

https://forums.comodo.com/help/rebuild_repository_folder_to_recognize_comodo_resolved-t2479.0.html;msg19751#msg19751

I’ve created a small batch file that temporarily turns off a Windows service, deletes the folder that contains the Security Centre info and then restarts the Windows service. When it has been run, you really should reboot to ensure the WMI repository (that’s the technical term for where the Security Centre info is stored) is rebuilt according to the currnetly installed security software.

PLEASE NOTE : The batch file will only work without errors IF your system doesn’t not have any other services that are dependant upon the Windows Management service.

If you wanted to do this manually, you will need to manualy execute the following three commands (shown in RED);

net stop winmgmt

rd /S /Q %systemroot%\system32\wbem\Repository

net start winmgmt

As to why the repository is such a fragile creature, ask Bill Gates. :wink:

Hope this helps,
Ewen :slight_smile:

Hello!
I face the same problem and the posted solution doesn’t work for me. By running the second line of the commands I just get the message that “rd” could not be found.
Windows Firewall was off before installing Comodo but before it turned itself off I updated Adobe Acrobat from 7.0 to 7.0.9 - might that be a reason?
Cheers!

What operating system are you running?

“rd” (or “rmdir”) is a standard internal command in XP, like"dir" and “copy”.

Ewen :slight_smile:

For our situation, things seem to have gone back to normal without running anything. Microsoft is also recognizing that we have a firewall. Reinstall of Comodo does mean all the programs we previously said ok to, we now have to accept again.

I am curious why the reinstall was required. Any idea? Beyond that our problem seems to be resolved.

Hi Ewen,
it’s a German version of XP Pro SP2. Yesterday Comodo worked after an exit/start of the program. Same this morning, but curiously in the afternoon it got moody, and went into this kind of freeze mode… After 3 times exit/start it was ok again. Any idea?
Cheers!
Roland

As I’m not a native Geman speaker, I couldn’t tell you what the Deutsche equivalent of “rd” or “rmdir” is. As to the intermittent freezing, I’d go to http://support.comodo.com, register (if you haven’t already done so and your forum login details won’t work on the support site) and lodge a support ticket on this.

Cheers,
Ewen :slight_smile:

Dear Ewen,
Ok, will do. Thanks for your time!
Roland