Network pc's not accessible after CIS7 install

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    I do not have to reproduce, it is an imediate problem after installing CIS7.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Installed CIS7 on Windows 7 Home Premium 64bit and Windows XP Home Edition & Media Edition 32bit.
    2:After reboot Windows 7 pc’s auto detected network, Windows XP pc’s did not.
    3:Added zone and IPv4 subnet mask to Windows XP pc’s.
    4:Open network neighbourhood on XP pc’s and only host pc is displayed. No access to other networked pc’s even if network address manually input eg. \
    5:Open network neighbourhood on Win7 pc’s and no pc’s are displayed, however if you refresh the page all networked pc’s are displayed but only Win7 pc’s are accessible, no access is available to WinXP pc’s.
  • If not obvious, what U expected to happen:
    CIS7 should auto detect network on WinXP after install and access should be available to all netowrked pc’s.
  • If a software compatibility problem have U tried the conflict FAQ?:
    No. All networked pc’s were accessible when CIS6 was installed and no changes were made to pc’s after CIS7 installed.
  • Any software except CIS/OS involved? If so - name, & exact version:
    No.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    No. Cause is CIS7. If CIS7 uninstalled all pc’s are accessible.
    [/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
4 pc’s installed with CIS7 v.7.0.315459.4132
Configuration - COMODO - Internet Security

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS - off
    Behavior Blocker - off
    Firewall - Enabled, Safe mode
    Network IP In - 192.168.1.XXX / 255.255.255.0
  • Have U made any other changes to the default config? (egs here.):
    No
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    Yes.
    1 Windows 7 uninstalled CIS6, fresh install CIS7
    1 Windows 7 upgraded to CIS7 via CIS6 updater
    3 Windows XP uninstalled CIS6, fresh install CIS7
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes
    [/li]- Have U imported a config from a previous version of CIS:
    No
    [li]if so, have U tried a standard config - if not please do:
    N/A
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    2 Windows 7 Home Premium 64bit SP1, UAC off, administrator, no
    2 Windows XP Home Edition 32bit SP3, UAC N/A, adminstrator, no
    1 Windows XP Media Centre Edition 32bit SP3, UAC N/A, adminstrator, no
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=No b=N/A
    [/ol]

Please try reinstalling by following the advice I give in this topic. Issues of this sort are usually able to be solved by reinstalling using those methods.

Let me know if this is helpful.

Thanks.

Was reinstalling able to solve this?

I followed the instructions as per your link.

2 x Windows 7 pc’s installed without any problems.
1 x Windows XP Home Edition pc installed without any problems.
2 x Windows XP Home Edition & Media Centre pcs had same results as bug report. Work around was to install CIS6.3.302093 (without any problems; auto detected network and allowed network access to all computers) reboot and run updater to install CIS7.0.315459.4132.

That is strange for the one computer. Did you verify that the network driver was in fact removed before rebooting into normal mode?

Thanks.

The network drivers were not removed and all network functions were normal before reinstallation of CIS7.
Surely there must be something wrong with CIS7 auto network detection within XP. On 2 XP pc’s CIS7 failed however after having to remove CIS7 again and installation of CIS6 auto detection worked.
Procedure on XP pc’s:
Bug reported
followed your removal instructions
install CIS7, failed to detect network, reboot and still no auto detection.
added network zone and submask address, reboot, still no network functionality.
Removal of CIS7 following removal instruction.
All network functionality is restored.
Install CIS6, network was auto detected and network functions as normal.
Reboot
CIS6 updater opened and install CIS7.
Network functions as normal and no more problems.

Okay, as a reinstall was able to solve this I suppose I will move this to Resolved.

Let me know if you run into any other problems, or if this issue returns.

Thanks.