Network Options

Thanxx for all the info.

Regards
Naren

Today for the first time I read the help files of windows firewall for network options & got confused a little.

The help files mentions

Home - At home, the network you know - This is fine.

Work - At work, the network you know - This is fine.

Public - Public spots like airport, coffee shop, etc AND computer directly connected to net i.e when there is no router/modem. But if there are many applications that needs to be allowed access network/open ports then its good to select the network as Home or Work as applications allowed under Public will be automatically allowed for all the Public Networks BUT remember selecting the network as Home or Work also reduces the security as the network access is allowed. Now I have direct connection so what should I select Home, Work or Public?

Thanx
Naren

Are you using Windows firewall, or are you using CIS?

This is my familys system Win 7 64 & all are average users & dont want to learn anything & if I will try to convince them more (I tried & failed) to learn about security I guess they will get irritated & beat me up :slight_smile:
So I have installed Avast Free with Windows Firewall & UAC enabled. This is the main system now too i.e directly connected to net (no router) & wireless is also configured on this system i.e (router is used when wireless connection is needed on other systems). Mostly this system is directly connected to net (no router)

Thanx
Naren

!ot!
Make sure your browser extensions/plugins are up2date, if you don’t need java uninstall it.
Use Secunia PSI to verify your system is in a healthy state.

Ronny,
System updates are set to automatic & time to time I check it. I always see to it that all the programs are up to date. I need flash & java so installed & set to automatic update & also check manually time to time. No specific extension here only Avast web rep.

Thanx
Naren

In addition to the excellent advice offered by Ronny, you basically have to decide which profile to use based on the needs of your family.

Windows 7 uses a process called Network Location Awareness to determine the kind of network it’s attached to and thus which profile to use, however Windows 7, unlike it’s predecessors, can also use multiple profiles simultaneously. What you need to do is assess your family’s needs and then look at the inbound and outbound rules associated with the public and private profiles offered by Windows, you also need to take a look at the Advanced Sharing settings.

Basically, if your family needs to share files, printers or media of other kinds, you’re probably best off assigning the network the ‘Work’ designator, in Network and Sharing centre. This will cause the Private profile to be activated for that network. However, you’ll need to assess the individual firewall rules for that profile, to make sure nothing is getting in or out that shouldn’t be.

!ot! I’m still not sure why you’re not using the router as the Internet gateway for your entire family?

Radaghast,
2 things are important here. Yahoo Messenger with which we chat voice/video with my bro in US, I am from India & Remote Connection sometimes with my bro.

With router voice chat is not happening i.e we cannot hear the voice, no voice. Can network selection be the prob here?

& the net speed I get is slow compared to direct connection. The browsing is fine but anything I download I get less than half the speed with router compared to direct connection.

Currently I am using Public Network but I am thinking of Home Network. 1 question - If I use Home Network for direct connection, is it possible for my ISP to look into my system or share anything?

Thanx
Naren

I would think both of those problems are configuration issues with your router/wireless NICs

Currently I am using Public Network but I am thinking of Home Network. 1 question - If I use Home Network for direct connection, is it possible for my ISP to look into my system or share anything?

If you’re referring to a Homegroup I’d say forget it. The security configuration is wholly inappropriate for a direct connection. However, you mentioned earlier that you use both direct connection and wireless on the same systems, with windows 7, it should recognise both interfaces and prompt you accordingly for the profile. If the wireless connection is secure, you may get away with assigning a Homegroup for those interfaces and then use a public profile for the direct connection.

So dont you think all these firewall options are kind of useless specially for average & novices.

As I said my family members are novices so when they see the options window without thinking they select Home coz they think we are at home so Home Network is right. This behaviour I have observed a lot in my frds & relatives & other peoples who are average & novices. So I think these options are of no help & there should be some smart firewall thing, but I guess its too much asking from microsoft.

About the router settings I will go through all the settings again & post accordingly & will also try to look into fw settings & advanced settings.

Thanx
Naren

I can understand your pain. Granted, the descriptions of where a certain type of profile should be used could be better, but NLA should default to public, if it cannot fine certain requirements for private networks.

OK. I have decided,

when router in use I will select Home
& when directly connected it will be Public.

I checked every router settings & its fine according to me & If I remember correctly you guyz & I have discussed quite a lot about the following & only single prob which I think is there when router is connected.

The prob is DNS server.
If I use router & under router settings, for DNS server I choose automatic from ISP as this is the setting of my ISP. But if I check through ipconfig /all, for some reasons the DNS server shows I guess its routers default DNS & not ISP’s. And the net does not works properly i.e mostly page cannot be displayed.

So currently I have entered my ISP’s DNS in wireless network adapter properties use the following DNS. In this way ipconfig /all shows my ISP’s DNS & the net too works fine i.e browsing is as usual fine. But I face slow download speed if I download anything compared to direct connection. The speed is almost half.

Thanx
Naren

What’s the make and model of the router? and what’s your Internet connection speed and type of connection?

Belkin G Wireless Router
Model F5D7234-4 v3

Pacenet Broadband Internet Connection
PPPOE Connection
4MBPS Connection

Wireless Adapter - Intel(R) PRO/Wireless 2200BG Network Connection

So if you connect ‘trough’ your router you use ‘Wireless’ right?
PC → 2200BG → Wireless waves → Belkin.

How do you connect ‘direct’
PC → Lan cable → Pacenet? or is the Belkin in between also?

PPPoE rings a bell for MTU issues, have you ever been using tweaking tools to ‘optimize’ your network performance on Windows?

What does Windows display for wireless speed and signal strength?
Or can you verify what’s around you and on what channels using inSSIDer

When last we spoke about the DNS issues, I seem to remember suggesting you ask in the Belkin forum for some help. Did anything come of this?

I didn’t asked in the Belkin forum.

Router for wireless only otherwise plugged off.

Direct connection - ISP’s setup on building terrace. A wire from that setup enters the apartment & is directly connected to the system, nothing in between wire & the system.

No cleaning or optimizing tools used.

Windows displays speed 54mbps & signal strength excellent.

MTU set to default & channel set to default 6. Tried changing the channel but no effect.

Intel wireless adapter settings defaults.

Just to make sure I remember:

  1. Your connection is PPPoE and you’ve configured the router with this connection type?
  2. Your connection is not MAC address specific?
  3. On the DNS page you’ve specified ‘Automatic from ISP’ ?
  4. DHCP is enabled and configured to lease addresses from a small range?

If the above is correct and you’re having problems, please configure the router accordingly, load the status page and attach an image here. or you can PM me with the details. Also, run an ipconfig /all for a wired workstation and provide the results.

For the wireless side of things, try the following:

  1. Make sure you have selected the correct wireless mode to match what ever adapter(s) you’re using
  2. Disable Protected Mode
  3. Disable Turbo Mode

It might be worth while resetting the factory defaults on the router, at least we’ll know there’s no user added settings affecting anything.

Radaghast,

  1. Yes

  2. It is MAC address specific & I have cloned the MAC address under router settings.

  3. Yes

  4. Enabled & set to routers default “forever”

  5. Mode is correct on both wireless adapter & router settings i.e Mixed 11b+11g

  6. Protected Mode is disabled under router settings. No such option under wireless adapter settings.

  7. Turbo Mode is disabled under router settings. No such option under wireless adapter settings.

I have kept everything routers default. Only thing I selected was PPPOE connection & configured it i.e nothing much required, just username & password. Router’s default was dynamic. And I cloned the MAC add as it was required as net is MAC address specific, without cloning net was not working.

Tried quite a few times with factory defaults but no effect.

Router has channel settings, auto & 1-10, default & set to 6
Wireless adapter has some Ad Hoc Channel default & set to 1 with options 1-11. Should I also set this to 6 like router or change router to 1 like wireless adapter?