Network firewall not functioning

I have just today downloaded and installed Comodo Firewall. Everything looked OK, but two things are bothering me:

  1. Under the summary tab, I get an error saying “The network firewall is not functioning properly”.
    I have no idea why this is coming up, as when I run the diagnostic it says Comodo has installed fine.

  2. I can’t work out how to open up a port. I use a UDP and TCP port that I need to open to share torrents. How can I add an exception in Comodo?

Welcome to the Forum, Texas.
Issue 1 needs resolving before issue 2 can be set up.
What OS are you using?
Do you have (any) other AV active or running on your system and what are they?
If ‘yes’ to the above, did you disable all other AV on your system prior to installing CIS?

I am using Windows XP (Service Pack 2).

I am running AVG antivirus. When I installed Comodo, I only installed the firewall, not the antivirus stuff.

Did you disable AVG prior to installing CIS?

It’s always a good idea to disable an AV when installing something. Some installers aren’t very graceful with another application trying to poke it’s fingers in there while it tries to do it’s thing. That’s why you always see that warning to turn off AV or other running applications.

Hi, I am also getting “The network firewall is not functioning properly!”
I am running Windows 7 Beta Build 7000.
Please see the attached diagnosis report.

[attachment deleted by admin]

With Win7 you must install in compatibility mode (Vista), then run CIS in compatibility mode. You also need to set cfpupdat.exe to compatibility mode in order to receive updates.

Thanks for all your help, but I disabled AVG and resinstalled Comodo, and I still got the same error.

I uninstalled AVG and reinstalled Comodo and I still got the same error.

I think I am done with Comodo. I am going back to ZoneAlarm. A bit of a shame, because I have heard some good things about this firewall, but it is all getting too hard.