network firewall not functioning properly [Resolved]

All of a sudden I got notices that CPF (v. 286) had an error and had to close. I tried reinstalling it, and still got the error, and if it opened it said “network firewall not functing properly.” I uninstalled and reinstalled v 378. The installation went smoothly but the Summary page still says “network firewall not functing properly”. I went into diagnostics and it reported problems and then fixed them. I shut down CFP completely and reopened it. After a long initialization, it again said “network firewall not functing properly”.

What does all of this mean, and what can I do about it?
My computer is a single computer and is not on any network.
I am running XP-SP2.

how did you uninstall CFP? windows uninstaller, etc…

did you make sure it was fully removed?

When I reinstalled, the installer first uninstalled the previous version. I didn’t take any other steps before reinstalling.

Something is causing serious problems on the computer and I am beginning to wonder if it is not CFP. That would be a shame because I have been using it for several years, and am not keen on switching to something else.

The problem is solved. I had called my ISP’s support because of a sudden loss of internet connectivity. He suggested some settings changes, but first I set a restore point. After those changes I began to experience numerous problems, but I didn’t connect it right away to those changes. After rolling back to the restore point, everything was fine.

Thank you!