Network driver not being installed [solved]

Just to report that I’ve tried to install the latest 4 or 5 betas (and RC) and in neither of them the network driver get installed. Tried in Safe Mode, tried uninstalling all antispyware/antitrojan/antivirus products.
I’m thinking this is related to some low level HP Security or Network driver.
I’m using Vista Business 32bits in a HP Compaq nx6320 laptop.

The Legacy keys in the registry aren’t installed.

COMODO Firewall Pro Sandbox Driver
COMODO Firewall Pro Helper Driver

are installed, but not the Network Driver related to inspect.sys. The file exists. The registry keys don’t.
I can install and see these registry keys into XP computer, but not in Vista.
The driver is shown as non-Vista compatible as you can see in the picture.
Also the network service is not installed on Vista, only in XP.

I’m attaching the diagnostic tool report also.
I’ve sent an email describing all this problem to the technical staff.
I’ve tried that Justin (Moderator) help me.
Sorry to open this discussion again, but I can’t solve and I’m not receiving any suggestion that really solve (or even discover) the problem.

One possibility is trying to post here, please, the registry key contents related to the inspect.sys driver. Are they as the same as XP?

[attachment deleted by admin]

I’ve forgot to add the diagnostic report…

[inspect]
Key=No
File=Yes

I’m quite sure something is avoiding the installation of this registry key…

[attachment deleted by admin]

bump.

I’ve updated all the network drivers from the manufacturer site.
Tested another time…
Again, no network installed, no help from comodo users or technical team.

[attachment deleted by admin]

3.0.13/Vista Ultimate/Avast!
Have you scrubbed the registry of Comodo stuff with regedit32 before you try to install? I saw cautions to do this for some of the betas, although I was not an early Comodo 3 user. You certainly seem to have a unique problem. Alternative might be to image (Acronis) your system so you can recover things later, reinstall Vista, then Comodo and see what you can do from there. Good luck; Ed.

Hi Tech,

But when you see this dialog, do you select “Install anyway” or you choose not to install? If you choose “Install” option and still observe the problem, then we may have an issue in Vista in (portugeese?)

Thx,
Egemen

Hello Tech,

I am with you, have the same problem(not unique). After a beta cpf in- and deinstallation there is no possibility to get a new functioning cpf. Installation is running through with a reboot.
During the installation procedure there is no dialog “Install anyway”, egemen. Cpf is there, but in no working status. Diagnostic tool is nice - can’t help. (:NRD)
Helping solutions are not available for that deficit. Wonder why there are not more users with the same expirience? Maybe one cause is my manual deinstallation of Commodo networkdrivers, cpf beta didn’t manage, together with registry entries wich are blocking a new install of networkdrivers.(crazy thougths) ???

So by now it is not only an issue in portugeese Vista (:TNG)

Vista Ultimate
AVG Free

cu 3e

I select ‘Install anyway’ of course, otherwise that will be the reason for not having the driver installed.
I watched the installation carefully and see that at first time (not using the diagnostic tool), that window popup instantaneously and, most probably, Windows is choosing not to install the driver. But, for sure, I choose ‘Install anyway’ and not a registry key is created…

Thanks for posting.
How do I remove all Comodo entries from registry?
How do I remove all Comodo files (out of Comodo installation folder)?
I’ve used all betas and, now that you’re talking, the first one could have worked and the subsequents don’t.

Which keys should I look for?

On regedit2, just do a “find” on comodo, and there should be some obsolete keys to delete. Proabably a first pass to understand what is there from comodo, then a second pass to remove the possible problems would make sense. You probably can’t delete the LEGACY keys, but there may be others that cause problems. Backup your registry (and computer) first, since the earlier betas were probably quite a bit more flakey in terms of registry use. The current version seems to clean itself out reasonably well when you uninstall. Good luck; Ed.

Hi Tech,

Normally, you do not nee to cleanup the registry. Even if there are some, they should not be important or causing this problem.

Lets try the following:

there is a folder called “c:\windows\inf”. In this folder, there are “.inf” and “.pnf” files. Please check OEM*.inf files. When you double click on an “.inf” file, pls check for “Inspect” or “COMODO” keywords in it.

If you find one(or possibly more), delete .inf and .pnf. Make sure you cleaned up all.

The setup does these things before the installation but lets see if this works in your PC.

Thx,
Egemen

I’ve done, although it shouldn’t be necessary.

I can delete them, key by key, with elevated privileges.

I have 1112 files in that folder.
The search for ‘inspect’ strings results on 2 files: setupapi.app.log and setupapi.dev.log.
The one for ‘comodo’ on zero files.
Should I delete all of them?

I have already done this process when trying to install the old betas, but was unsuccessful.

I’m quite confident that the problem is the compatibility of one of HP network drivers with Comodo network drivers. Is there any way to troubleshoot or should I give up on Comodo?

no you dont need to delete them. Can you post those setup api logs?

It may be some other NDIS driver installed. What is your ethernet card? Can you give me the information about those HP drivers you have installed?

Thx,
Egemen

I’ve moved them from that folder.
They’re zipped bellow.

Thanks for the help Egemen.
The drivers are available here.
More specifically, this is the direct link for download the setup file.

About NDIS drivers, won’t be better a snapshot of my system.
I have Fresh Diagnose and PC Wizard and I can install other hardware/drivers monitor to get a full snapshot of my system. Can you suggest any? Is there any Network Monitor that monitors (and extracts info from) the Network Driver Interface Specification (NDIS) 6.0 drivers in Windows Vista?
I’m far from being an expert on drivers/hardware issues.

[attachment deleted by admin]

[attachment deleted by admin]

The setup log tells me that the error is “There are no compatible drivers for this device”. It is not an expected error type. Are you using "HP Compaq nx6320 Notebook PC " ?

There is 1 more thing you can try. You can try to install CFP Firewall Pro Driver manually. In the Firewall\Repair directory, we keep inspect*.inf and inspect.sys. “Install->Service->Have Disk” like installation. But I will post the exact steps on Monday as i dont have Vista here right now.

Egemen

Sure…

I can wait (and will). Install manually is not a thing to do without knowing exactly what you’re doing.
But, doesn’t this error shown that the Comodo driver is not full compatible?

[attachment deleted by admin]

Nope. That dialog is just about NDIS driver signing dialog. Normally, you must not have seen it, which is another issue that should be identified.

Waiting patiently… (L)

Sorry about being late. Will be posting today.