Network card issues with comodo.

hi my names sean…im runnin windows vista home premuim cable modem a linksys wireless wired router and a comcast modem… im sorry i dont ahve any of the screnshots to show you :frowning:

i have found a solution for my problem and id like to tell you what i did to solve it… and learn from you how what i did may be dangerous or was the right thing to do.

the term id use is network inconnectivity., when id log on or turn on my computer would only read the local network, so id turn on my laptops wifi and id get signal and connect. so i figured it was a problem with my network card… so i hit diagnose and repair, it worked once…restarted my machine and it started all over agian!!
so im gettin frstrated by now… so i look around for a solution… alotta stuff talkin about zone alarm bein the culprit but i didnt see anyting bout my firewall comodo, so i tried everyting from uninstalling the drivers for my network card to literally installing a new network card…(i have alotta spare crud layin around). nothin… so i went to bed… logged on with my laptop the next mornin to get this problem solved. and i saw one suggestion to uninstll my drivers and disconnect the cable shut down pull the power cable hit the power button discharge my system completely, wait 5mins or so… hook it all back up and it should work after hittin diagnose an repair…
so i try it and it works again! thought i licked it… i surf chat with my sweety etc, need to restart again so here it al comes back again… so i came to just doin a fresh reinstal of my windows completely… vista home premium…i had connectivity again haasah! so i go get avira and comodo my preferd pair for secutiry on my pc’s. i install avira restart still have network… install comodo and low and behold im local only… so im confused… never had this happen in the 3 years i’vebeen using it… came from zone alarm (barfs) .

i have managed to determine what the problem is being caused by… i hit the comodo forums lookin for others with my issue, not alotta ssimilar cases but close. i found one posted by a fine moderator here talking about the global rules… so i ask my neighbor whos the “IT” guy of the network im on here and he suggests i go to global rules and see what blocked’s i had… so i get htere and i have 5… they all had different ends like echo request etc etc… “Block Any ip from ANYwhere” was the common issue amongst them all… so he tells me to just delte the rules… and bingo i have my internet.!!!

so what i ask now… what in the world would be causing the default settings to show up in this manner blocking my internet, when for 3 years tthey never prevented my surfing.

could it be that im running through a switch box from my end to the router and modem on his end?

i hope my small essay here helped others find solutions and learn from my problem, and i look forward to tryin to help anyone else with this or get help in better understanding WHY :slight_smile:

thanks EricJH, sean