network application monitor

First i must say i think comodo firewall is a great product but i seem to being having a very big problem with it.

Whenever i launch a 3d application say like half life or world or warcraft the aaplication monitor may pop up and ask for rights before the said game loads but on many occasions the 3d application will load and comodo firewall monitor doest seem to pop up on top of 3d application so the game iam trying to get access to the net wont be able to connect because commodo pop ups dont show up on top of 3d applications,and causes the games to stop responding,this isnt a problem with all games as i can alt-tab to windows to allow but not all games are alt-tab friendly.

Maybe theres a setting ive missed in control panel to set always on top but i cant find it,is this a bug due to be fixed because ive had to uninstall this firewall and i really liked it.


I think some games are always on top (full screen). Either they have a setting in them for running as a window or you need to manually allow the application using Task Add new application rule. Allowing TCP/UDP IN for that application.

This has happened to me with all the FWs I’ve used including now CPF.

Most games will let you break out of them to the desktop in order to reply to the popup. There are a few ways of doing this, At-Tab, Alt-Esc, Ctrl-Alt-Del to bring up the TaskManager will also work. Sometimes entering the key sequence many times in a row will do the trick. Even if you ■■■■■ up the game at least you can add the rule and then restart it again.

Of course if the game is so clam-tight as to not let you break out of it then you have to add the rule yourself.