Netgear drives missing [RESOLVED]

I have found some similar posts on this here. Unfortunately, all seem quite full of jargon I can’t understand.
Be patient as I explain my situation.
I have a Netgear SC101 connected to my router. Last week the 2 drives appeared in File Explorer and were accessible normally. I remember doing nothing in CIS to get the drives to work. They worked perfectly as soon as CIS installation was finished.
Yesterday I upgraded to the newest version of CIS. Since then, the SC101 drives do not appear in Files Explorer. I have opened(?) UDP 20001 as suggested in one post here. No change. I added the service to TRUSTED (I think). No change. FWIW, every few minutes (literally) I get a tone from my PC which usually occurs when a device is connected. (Actually, I get 2 tones; one indicating a device has been attached followed by one indicating a device has been detached.) Am I certain this tone is related to the SC101? Nope.

The following has worked with other NAS devices with other versions of CIS.

  1. Open CIS
  2. Click FIREWALL
  4. Click the ADVANCED tab
  5. Turn off “Block fragmented IP packets”
  6. Click OK
  7. Reboot (just to be sure the modified settings are read and initialized)

Let us know if this helps,
Ewen :slight_smile:

worked perfectly. AND jargon-free. Thanks

Simple solution from a simple mind. :smiley:
Glad to hear its all working for you.

Ewen :slight_smile: