Net connection betwee 2 PC [Ping -telnet-etc ] - [RESOLVED]

I am using CIS for years (old ver also ) never had a problem but now i have 2 pc in house

PC1 - Connected Directly to Router via Ethernet Cable

PC2 - Connected to Router via WLAN (Router >Belkin USB WLAN)

PC1 and PC2 is both able to access net

PC1 192.168.1.2
PC2 192.168.1.5

Under Homegroup i am able to see PC1 and PC2 also TeamViewer is able to do remote desktop and FTP etc

BUT i am unable to Ping to pc 2 , telnet , remote desktop to pc2 and vice ver

i did try add Firewall > NSP>GRules>Add>Sources add>Host name>added Host name of PC2 on PC1 and PC1 on pc2 > ok apply

still i am unable to do ping,telnet,remotedesktop etc

Please help

http://img834.imageshack.us/img834/5028/pc2firewalllog.jpg

Have you selected the first option in the Stealth ports Wizard?

Please follow Boris’ Instruction

CIS > Firewall > Network Security Policy > Network Zones > Select a Network Zone that has your IP > Add > New Address > enter the IP Of the other Machine > Ok > Ok

If you’re using Windows 7 Homegroups, in addition to creating a trusted connection via the method mentioned by Boris and Jacob, you’ll also have to make sure svchost.exe also has full connectivity between members of the group.

Radaghast is correct; To do this easily
CIS > Firewall > Network Security Policy > select svchost.exe > edit > copy from > another Application > System

(If svchost.exe not found please add it)
In Network Security Policy > Add > Select > Running Process > Svchost.exe

Tip: Make sure you click Ok/Apply

Kind Regards

Nop , i only added rules under NSP>Global Rules

Now i selected 1 option on both pc’s and entered IP accordingly

added now

Do i need to add 4 or 5 svchost.exe ?

btw now i am able to ping to 2nd pc sucessfuly

but telnet not possible , i guess it will b fixed once i add all 5 svchost.exe ?

Only 1 Svchost is needed;

Kind Regards :slight_smile:

did now But

when telneting i am getting error connnecting to 192.168.1.2 … could not open connnection to the host on port 23 connection failed :expressionless:

(if need to post ss of any config. pls say )

Thank u 4 fast reply

Your Welcome;

Can you post Global Rules? and the Application Rules showing Svchost and system

Thakns

SS from PC 1


config of pc

IP          192.168.1.2

PC2 
IP 192.168.1.5

Both pc's are able to connect Internet 

Posted SS from PC1 (3) and PC2 (3)

GRules
NetworkZone
svchost

[attachment deleted by admin]

Please Wait While I Review Your Uploads :slight_smile: (15 Minutes)

Kind regards

sure np . thanks u vm

There are a few things you might want to look at. First, change the rules you have created for svchost, as they are not very secure. Use the method described by Jacob in his earlier post

CIS > Firewall > Network Security Policy > select svchost.exe > edit > copy from > another Application > System

You might also want to change your zone information, as you have overlap:

In one zone you have:

192.168.1.2/255.255.255.0
192.168.1.5

192.168.1.5 is in the same subnet described by 192.168.1.2/255.255.255.0 so you don’t need both entries. just remove 192.168.1.5. Also change the first line to 192.168.1.0/255.255.255.0

In the other zone you have:

192.168.1.5/255.255.255.0
192.168.1.1 - 192.168.1.10

This also makes little sense. change the first line to 192.168.1.0/255.255.255.0.

If you need to place computers in different subnets, you either need to change the mask or change the number in the third octet.

With regard to telnet, I don’t see entries in Application riles for either a telnet client or a telnet server. In Windows 7 neither the client of server is enabled by default, they have to be turned on through Programs and features.

CIS > Firewall > Network Security Policy > select svchost.exe > edit > copy from > another Application > System

Done


n one zone you have:

192.168.1.2/255.255.255.0
192.168.1.5

192.168.1.5 is in the same subnet described by 192.168.1.2/255.255.255.0 so you don't need both entries. just remove 192.168.1.5. Also change the first line to 192.168.1.0/255.255.255.0

In the other zone you have:

192.168.1.5/255.255.255.0
192.168.1.1 - 192.168.1.10

This also makes little sense. change the first line to 192.168.1.0/255.255.255.0.

Done and attached Pic

With regard to telnet, I don't see entries in Application riles for either a telnet client or a telnet server. In Windows 7 neither the client of server is enabled by default, they have to be turned on through Programs and features.

Yes i do know that , Its installed on both PC’s

edit

:-\ sry all i rechecked everything and found even though telnet was installed on both systems telnet service is disabled in services >.> , its working now

sry all and thank u all for helping me fix

[attachment deleted by admin]