Need to totally remove CIS from computer

I am new to this forum and hope I have put this in the right area.
I have run CIS for at least 1½ years and have really liked it.
CIS told me and update was available and I tried to install it. It would not let me. It said it could not install And gave me an error message #1603.
My CIS became un useable and I can’t install fresh.
I used Revo Uninstaller to remove it. There is nothing in the Start menu or in the Add/Remove section for removal or even a listing for CIS.
I went to Forums and found some info and it did not help my problem. I downloaded the Removal tool batch file and that did nothing for me.
I can’t even install just the Firewall.

I have such a mess right now, I need to totally remove CIS from my computer.
Any help would be greatly appreciated…

Dell 8300, WinXP SP3 all up to date. 120g HD 1 gig ram, Pentium 4.

Thanks - MAKRLM ------

there is something left over.

run the batch tool in safe mode, reboot into normal mode, run the batch tool again, reboot, go to networking, change adapter settings, right click on your network connection and go to properties, look for comodo firewall diver, if listed select it and click uninstall, reboot when done. Now try installing again.

Wow… Can’t it be easier? I mean, can’t CIS manage this situations automatically?

Revo Uninstaller is not a panacea. It’s far from being so. Specially it’s not good on removing antivirus/firewall or any other application that requires reboot to be uninstalled.

Why is it so difficult for some people to uninstall V3? ??? It just seems to me that you don’t usually have this much trouble when upgrading to the newest version.

What’s different about V3 to V4?

I never had a problem removing any version of CIS and then installing another one. When I ran the removal tool after a normal uninstall through CCleaner’s GUI, it never found anything left over. It’s strange how some people have problems.

Years ago I could not update Comodo because a tree of 2000 registry keys filled with values was stuck.
Even RegEdit could not delete them due to permissions issues.
I eventually manage to take ownership and then I was able to delete them

Last year the “Official” removal tool rushed through with a screaming mass of errors for missing files and folders that it wanted to delete but could not find because they were already un-installed. I also saw a few “access denied” messages with no clues upon what files / keys were involved

This is why on Page 3 of that topic I submitted my version which follows the “KILL” phase with a LIST phase that shows things which Windows would NOT ALLOW to be deleted, and not only allows close inspection, but states the name / location of the frozen item. The summary totals at the end identify anything stuck by the O.S. that needs manual intervention.



Are you saying that you wanted to use Revo but didn’t see anything to uninstall?
Because I noticed that CIS doesn’t show up in my Revo list, but it does show up in CCcleaner.
Maybe you should dl CCcleaner and see what happens…it’s a good program to have anyway.

Hello again,
I ran the removal tool in safe and regular mode.
I went to “Search” and located a bunch of files and deleted them.
It appears that it is all gone now.

Thank you everyone that responded to my problem…


Hello, this may or may not be of any interest on this matter, but whenever Ive had to uninstall comodo (I use the Firewall only) I go into computer management/device manager, and under view choose “show hidden devices”, there are a couple of Comodo entries there, right click and uninstall, then remove the program with Revo. No problems. Might help someone someday, Techdunce :slight_smile: