need help with updating

I get this following error when trying to update

“cfp.exe: The file download was aborted abnormally. The file is incomplete”

at about 5%, I tried rebooting and it didnt solve it, is there anything elseI can try please?

thanks a lot

From what version are you trying to update?

thank you Im trying to update from version Comodo Internet Security 5.4.189068.1354
from a few days ago to the very latest update that has just been released

Not sure what is going on. It took several hours before all the Comodo servers were synched so everybody could update. It was said earlier that was done. Is the problem still occurring at this moment?

Can you run diagnostics and see what it reports and if it can be fixed?

diagnostics didnt find anything…
each time I run the update some other file cause it to abort some time its cmdagent.exe sometime its
cmdinstall.exe and sometimes cfp.exe
at the moment its cmdagent.exe
but 5 min ago it was cmdinstall.exe…
what can I try?

i had a problem with the update stalling at copying cmdagent.exe so i just uninstalled and did a clean install and the update went fine. idk what happened

I can try to do that but is there a way when uninstalling to keep my custom choices for CIS I made a while ago so when I install from scratch I wont have to go and customize it again? also will I have to re-train my firewall?

You can export your active configuration from Manage My Configurations (under More). Safe the file in a folder that is not part of the CIS installation folder.

When you are installing the new version don’t reboot but import the saved configuration under Manage My Configurations then reboot. When importing it give a different name than the standard names. F.e. CIS My Proactive Security.

Also, before uninstalling, make a backup of your “database” folder in the CIS installation directory. After you install the new version, copy it back to the CIS installation directory. These are your Trusted Files and they don’t get saved when you export your configurations.

ok I did it that way(clean install) and it worked and thanks for the tips of how to keep the old config