Need Help Updating to Newest CIS

I am very very sorry if this has been answered before, but I have searched (both these forums and many others) and have not found a solution to my problem.

I have an old version of CIS that I installed a few years ago. It stopped being supported some time ago, so I don’t receive updates for it any more. I would like to remove it and install the latest CIS. However, this seems to be impossible.

I can remove my old version of CIS, but when I do I can no longer connect to the internet and am unable to repair the problem. I tried installing a new version of CIS hoping it would fix the problem, it did not. I tried using the Comodo Software Removal community tool, but not only did I not have an internet connection after that, I didn’t have a LAN connection either. Every time, I need to restore to my restore point I created prior to removing CIS.

I tried this about a year ago and ran into the same problem, unable to find a solution I just decided to live with an old an unsupported version of CIS. This is really my last chance, with this forum. If I can’t find the answer here, I will just have to live with the old version till I reformat eventually.

Please please please tell me how to remove my old CIS, install a new one, and still be able to connect to the internet.

Here is a bit of my relevant system info:
-Dell XPS
-Vista Ultimate 64-bit
-avast! anti-virus

it sounds like the firewall driver is still present. try going to network connections properties and see if the firewall driver is present if so uninstall it.

[attachment deleted by admin]

I found the driver you reference. I tried uninstalling Comodo again, then went to uninstall the driver, but the driver was not there after the install. When I try to diagnose the problem with my connection, the message I get is that the computer cannot communicate with the DNS server ( I have tried both leaving the DNS settings as they are and changing the setting while uninstalling, neither makes a difference. I am restoring my computer back to before the uninstall now.

Any other ideas?

Make sure that the settings for Internet Protocol Version v4 (TCP/IP v4) are set to automatic.

When that does not help open the command prompt and run the following commands:
ipconfig /release
ipconifg /renew
ipconfig /flushdns