Need Help Configuring Firewall For GGPO

Hello! I have this online game program GGPO here and I’m having a lot of trouble getting it to work. Now, I went to and setup a static IP of the “192.168.x.x” form. However, I’m seriously confused on how I need to configure the firewall for this program.

Inbound/Outbound: 6000-6009 UDP
Outbound: 7000 TCP

^^That is what the website lists as the ports that should be opened for the program. I’m getting almost 30 “intrusion attempts” every time I want to try to connect to someone with this program as well. The only thing is, is that when I look at the intrusion attempts, they are listed under “Windows Operating System” rather than GGPO and it doesn’t seem that I can change any rules under WOS. Also, these attempts seem to deal with the source ip of my router and the destination IP of my static address.

In addition to all this, I have setup my firewall under “Attack Detection Settings–>Miscellaneous” with all of the security options checkmarked as well as both options for ARP protection checked under “Attack Detection Settings–>Intrusion Detection”

Could anyone give me any clues on what I may be doing wrong?

You need to add a rule under Global Rules to open the ports 6000-6009 UDP for incoming traffic.

Go to Firewall → Advanced → Network Security Policy → Global Rules → Add → now fill in the following:
Action: Allow
Protocol: UDP
Direction: In
Description: Open ports for GGPO incoming traffic

Source Address: Any
Destination Address: the IP in the 192.168 range you set.
Source Port: Any
Destination Port: A port range → fill in 6000-6009

Now Ok and Apply your way out. When done go to Global Rules and make sure this rule is somewhere above the basic block rule(s) at the bottom (red icon(s)).

Now you have your ports open for incoming traffic.

Now set the application rule for GGPO to Trusted Application (that’st he easiest way).

Thanks for the information man. One question though: If the firewall is still blocking something related to this, would it fire an intrusion attempt? I’m asking because I’m still having trouble connecting to anyone, BUT when I try to connect to someone and watch to see if an intrusion attempt gets fired, one doesn’t.

When I look at my intrusion attempts now, I see some attempts fired for WOS that deal with the source IP of my router, the UDP protocol, a source & destination port of 1900, and also what appears to be the destination IP of an outside address. Additionally, I see intrusion attempts that deal with the ICMP protocol, a “Type(3)” source port and “Type(0)” destination port, and lastly a destination IP of my static address.

I don’t see anyone mentioning connection issues as of late on the program’s forums, but I’m hoping this is an issue on their side.

I am not sure why you are still having problems conneting. Can you show me screenshots of your Global Rules and for the Application Rules of GGPO? Can you also me a screenshot of the firewall logs?

The intrusion attempts you report are mostly chatter. The ICMP request you describe is an echo request for example ( Internet Control Message Protocol - Wikipedia ). The other report, port 1900, is a Universal Plug and Play request from your router.

To allow the uPnP requests it is best to make your local network a trusted zone. I will instruct you about it after I have the screenshots.

Keep us posted.

Here’s two firewall logs. One after I wiped all past logged intrusion attempts and one before.

Also, this program can’t utilize it, but isn’t it usually a bad idea to use uPnP?

[attachment deleted by admin]

You said not all connections with other users were working. Please make sure that source address and source port are set to Any in the rule under Global Rules. Can you show me your Global Rules and Application rules?

To get rid off router chatter we are going to define your local network we then add to the Global Rules using the Stealth Porst Wizard.

Go to Firewall → Common Tasks → My Network zones. See if you have a network detected by Comodo which shows: IP In Give it a name like My Local Network. Select the network → Add → A New Address → now add the following addresses:

When there is no network defined like that we will create one. Click Add → A New network zone → give it a name My Local Network → Ok.
Now select the network → Add → A New Address → now add the following addresses: (use “An IP address mask”)

Open the Stealth Ports Wizard under Firewall → Common Tasks. Choose “Define a new trusted network stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → from the drop down Zone Name choose My Local Network → Finish.

To get rid off some of the ICMP logs follow the steps from 11 in this post by Bad Frogger:;msg230413#msg230413 .

Thank you very much for the help man. I decided to uninstall the firewall completely to see if it was even the problem and it turns out, just as I suspected, the firewall wasn’t. I’m still going to re-apply these rules you helped me make, but it looks like I’m going to have a time figuring out what this issue is really linked to.

Good luck with that puzzle. Let me know if you need any help with it.

I got to the bottom of the issue. Turns out it had something do with the program’s sound being disabled 88). I’m still kind of glad this happened though. This experience really forced me to learn how to use this firewall the correct way instead of just lazily using only default settings.

As so often is the case that is what got me involved with Comodo in the first place