NEED Help ASAP please...OS wont load now <read story> lol

NOTE TO MODS Sorry for the double post on this entry, but wanst sure if it would be better for a new thread…thanks MODS).

Machine: Dell 9100 Laptop
OS: Win XP Pro. SP2

Well this issue apparently hit me too. Now I have a urgent issue to try to resolve. Got the missing or corrupt hal.dll messgae @ boot after installing CAVS from www.im1.net. Tried to expand d:/…trick on hal.dll, seemed to copy over find. Rebooted, issue with ntoskrl.exe, did the expand d:/…on that file too. Then upon reboot got an un specified .dll error message, contact vendor . Opted to do a repair-install of XP Professional. Here is where my issue is currently.

During repair-install, prompted for comodo antivirus 1.0.msi, searched the HD for it…not to be found. Hit canceled. Prompted a few more times, kept hitting cancel. Finally it passed that stage. OS looked like it repaired it just fine, as I was prompted to login and it still have my username in there. Upon logging in, my background picture came up as normal and then installshield popped up, once again wanting the comodo.msi file.

Tried to boot into Safe mode to maybe uninstall it, but was once again prompted for *.msi file while desktop was loading. I then tried to login as Admin account, thinking maybe Comodo didnt install on that profile…wrong…same prompt asking for *.msi file.

I am currently at a loss. I can not use my jump drive/LAN connection. My last resort will be to remove laptop HD, connect to my IDE adapter, transfer all my date to dump HD, and reinstall a Retail XP Pro OS. As I cant use the Recover CD, since my HD crashed and the new one they sent was not setup with CAB files to use recover CD…

ANY suggestions/help so I dont have to take this step would be GREAT. Like maybe via DOS or sending me the *.msi needed file :dontknow:. As once prompted, I can navigate to CD/DVD source…

PLEASE ADVISE

I’m confused. You say the HD crashed. Do you mean Windows or the hardware? If they sent a new one, I’ll assume it’s the drive. Is Dell telling you that a Windows installation is dependant on cab files located on the drive? That just isn’t true. The recover CD should be a complete OEM XP installation and not at all dependant on anything except working hardware.

If you’re unsure, call Dell support.

As for the msi issue? I dunno, but I have seen several posts on the forun with references to a older version of installer.

Hi,

Can you also make sure to send this to support@comodogroup.com

The hal.dll issue is still unresolved, as you know from your other post, but the more information Comodo gather about the computer specifications this affects the better.

Mike

You need to read his statement more accurately. It is clear that he used the STANDARD WinXP installation CD that comes with his system.
When you do a repair installation if there are programs/drivers that integrate into the system there will be dependencies for the program files. Windows will want to try to reinstall those files, unfortunately.

Obviously CAVS installs as a service too and is idoneous for this type of behaviour.

The only way around this is to try to reinstall the app/driver in safe mode and then uninstall it afterwards in normal mode.

Edward

Ahem… In which line is that clear?

Dell ships OEM versions branded for Dell hardware.

Instead of acting pedantic, maybe you could offer a solution?

The behaviour described happens ONLY when using WinXP install disks. Notice that you can ONLY do a repair-install with installation disks and NOT with custom drive images.
I’m definitely not trying to be pedantic, but you should know that what he has experienced is pretty much “standard” when you do a repair-install with an app that has installed itself as a service or has installed drivers into the system. The repair-install doesn’t automatically wipe your registry and all the info regarding services/drivers since it is not capable of knowing what every single driver in existence does.

The standard procedure to fix the situation is to try to ignore all prompts regarding the installation of the files pertaining the problem app and then REINSTALL the same app over itself afterwards. There is no other easy way to get rid of the problem without having to manually correct things.

In this particular scenario after CAVS is installed, it must be uninstalled. But there is no way to uninstall it without installing it first (besides manually messing with the registry and deleting appropriate files).

Sure it’s possible to get rid of it manually, but I’m not assuming that anyone is technically savvy.
They’re instructions for the common user… which normally happen to work for techs too.

The same thing would happen if you were to do a repair-install while having IE7 Beta3 installed on your system. The install would ask for files that are no longer easy to obtain, that is the reason why Microsoft instructs to remove IE7 BEFORE doing a repair-install.

Edward

Do you use CrapCleaner(CCleaner), cause if you use it once in a while, you can have problems with CAV.

Well Golly!,

Accuracy may well play a part in this after all.

I read…

and reinstall a Retail XP Pro OS. As I cant use the Recover CD, since my HD crashed and the new one they sent was not setup with CAB files to use recover CD...
to mean that he did not already have a retail XP CD at his disposal.

I also understood his situation to be critical and invasive. If he can get past the request for a msi file in order to do as you’ve prescribed, then it may indeed fix the issue long enough for him to properly uninstall. I wonder which version of the installer was used in the first place or if he even has it available any more. Since he got it from a source other than Comodo, he may have to return to that source for another copy.

Excellent suggestion! :wink:

Edward