NBNS responses seem to be blocked. How allow

NBNS responses from another machine on my local network appear to be being blocked by Comodo. This means machine names on the local net cannot be resolved to IPs.

I went to global rules to add a rule to allow NBNS from the local net, but it is not a protocol available in global rules to be selected. So how do I set it to allow NBNS responses to come in?

Aside: it was also blocking pings, but I opened that up with a global rule to allow ICMP Echo Requests from local net (which is defined as xxx.1 to .255).

Nevermind.

Further research and troubleshooting today-- and I got it to work. I solved it by making a global rule…

Allow UDP In
Zone = my defined local net
destination address = any
source port AND destination port = 137 (NBNS’s port)

I am surprised this is not a known, huge problem with Comodo, and there is not more known about it. It would seem to rear its head often as people tried to connect to printers, NAS’s, other computers on their net that had share points, etc. by using the machine name. I would have thought this would be a well known issue.