MySQL on localhost/127.0.0.1

Wondering did anyone ever solve the comodo driver issue with mysql localhost connections?

COMODO firewall driver installed → Only connections to external IP can be made
COMODO firewall driver not in use → Connections can be made through external IP & 127.0.0.1 / localhost

So, it’s pretty clearly comodo issue. This is clearly not allowing below firewall driver loop back connections.
(please don’t ask for did I set ‘firewall rules’ or ‘Global rules’ I am not an idiot of course they were set to even level disable firewall.)


System: Windows 7 x64 (no other security was on use while testing and no routers, modems anything either.)
Comodo Internet security v4.0.141842.828

Can you enable alerts for loopback under Firewall → Advanced → Firewall Behaviour Settings → Alert Settings?

Then show a screenshot of the firewall logs? They are under Firewall → Common Tasks → View Firewall Events.

What configuration are you using? The default "Internet Security"config?

The way I deal with loopback / localhost IP issues is I’ve established a zone for 0.0.0.0 a zone for 127.0.0.1 (called local_0 & local_127 respectively).

Once I’ve determined what IP protocol is at issue (src to dest) and on what ports and for which application. Then I create explicit rules allowing the speciic protocol from zone_0 to zone_127 accordingly (or vice versa).

Likewise I have seperate zones for NIC, modem/router/gateway & DNS servers resepectively. I plug in the appropriate zones into the src dest fields by application as necessary.

If you set up a zone to cover protocols TCP and UDP in and out for addresses 0.0.0.0 and 127.0.0.1 and apply that zone in a global rule, you have established a valid comms path. Secondary to that you may need to create (or allow CIS to create) an application specific rule for MySQL.

This is all I’ve ever done to allow MySQL connections and it has worked flawlessly for me.

I realize you didn’t want to be told this, but this is the answer. If you set it up properly it works.

Cheers,
Ewen :slight_smile:

That’s not an Issue.

Start mysql, open the Firewall, make a rule for mysql and you are done.
If you said the Firewall at the beginning that you want to receive connections from the NET (on the Network detection after the first start) you have no Problems from the beginning.

But you can only do that if you have a Private LAN, not a good Idea to allow connections from the NET.

LordRayden

To ensure that you are not accepting requests from outside your private LAN, you could set up a BLOCK rule but use the EXCLUDE option to exclude a zone that covers the internal addresses of your LAN.

Gotta love EXCLUDE rules - they make management much easier.

Ewen :slight_smile:

Please do not lock an subject you have not studied nor resolved by any mean.Mod note by EricJH: I reopened your existing topic and merged your question with it.

the 0.0.0.0 → 127.0.0.1 does not solve issue by any mean. neither does mysql rules set. as issue always was on to mysql client side.

Global rules are ineffective as even if you add 0.0.0.0 and 127.0.0.1 and application as allowed IP > Any, Loopback 1-2, any protocol. The client still will kill connection on either trying to connect to ‘localhost’ OR ‘127.0.0.1’ on server port. COMODO simply doesn’t allow the connection go through correctly as it stops EVEN if you disable the Firewall.

and as asked before message of firewall log of course there’s no blocked log entry how could there be?

Replicate the issue:
MySQL v5.0.45 x86/x64
MySQL v5.1 x86/x64
MySQL Client using OLD_PASSWORD.

try connecting localhost:3306 on client = not working even while firewall is disabled and no other firewalls are on neither system nor below the system.

Seems that the issue here is in socket level think I found it now.

If client binds sockets to external IP or internal 192.168.x.x or 10.x.x.x addresses the socket cannot connect and so that makes the client unconnectable to ‘localhost’ or ‘127.0.0.1’. Kinda weird issue, but by removing the bind (if possible in my client case not sadly) it would see seem the usual mysql works.

So, there’s the resolve to this issue.

My apology for blaming comodo driver as culprit. Seems problem is found elsewhere after all.

Congrats on solving the problem and thanks for reporting back to us.

i have tha same problem with mysql and sam broadcasting…
please tell step by step what to do to fix this

how do i remove the bind?

actually, i found out that mysql55 isn’t running as a service…

and when i try to run it from task manager i get the below error message:

“Error 1067: the process terminated unexpectedly”

any help?

any help about the above?