My laptop hangs and Reliability history says cavwp.exe does not work anymore.

Dell Inspiron 5770 Windows 10 x64 Windows 1809.
I was having problems with the full scan. It takes more than 6 hours.
I read in the Comodo forum that there was a new Comodo version. I checked mine and I had an older version.
I installed the new Comodo (12.1.0.6914) but did not uninstall previous version.
I remember having had problems with the installation. Somewhere a crash was mentioned but installation continued.
Today I had problem that laptop hung - I had to kill and restart it.
In the reliability history I see critical occurence cavwp.exe does not work anymore.
I ran the debug view (it keeps running) but do not know what you mean by this:
Using cmd.exe, run firewall installer with the following parameter:

I think the best thing would be to reïnstall Comodo after removing old version and using a cleanup program (could you give me the link?)
After that could you tell me which program to use to reïnstall Free Comodo? I have found 3 different exe files on the internet (see attachment)

I add the debug view file

I just read Eric’s Sticky on Reinstalling Comodo.
That seems to answer all my questions.
Will try that now.

12.1 has a known issue with cavwp process crashing which in turn causes system freezing, latest beta fixes this issue, so install the beta or wait for next stable release.

Thx for the quick response .
Meanwhile I reinstalled using the link from Eric’s Tread:
cispremium_installer_138430008_dd.exe - is this the beta???

After installation I got a warning - I thought I saved it somewhere but can’t find it it was about a ?program not being installed I think

If what I have is not the latest beta could you give me a link to the last CIS that is OK?

You are most likely not running the beta has it requires specific instructions to install beta builds. If you want to use a stable build that is not 12.1 then you need to search for an older version offline installer.

This really does not help me much.
I now have a computer that is constantly closing down.
All this started because I read in this forum that there is a new build.
I then read Chiron’s sticky here in the forum that has a link that points to the build that I installed.(Comodo Forum)
If this causes crashes - and it does - many times a day - the link should be changed!!!

So can someone help me to get the latest working build?

Sadly I am not getting any help here.

It is best to either use the 6882 or the beta as futuretech suggests. Build 6914 can cause serious instability on systems and should have been revoked as far as I am concerned.

You can download 6882 from MEGA . Comodo does not keep a repository of older builds that’s why you have to download 6882 from Mega.

When needed you can use the official CIS uninstaller which can also be run in safe mode.

Eric,

First of all - sorry for responding only now.
I was away all day yesterday.

I am so glad you responded. Sorry for double posting but I am in a real mess here. As said I am using Comodo since some 18 years and have always been extremely happy with it but now suddenly my Dell laptop that was running like a charm is completely messed up and all this because I installed a version that seems to be the cause of all this. This version I got using a link in the guide of how to install a new version of Comodo.
I am the one that has taken over your job for the dutch translations. As you know sometimes you need to put in quite some time now and then. That is why I was quite angry not getting proper help. Futuretech suggested a betaversion but I have no idea where to find it. I will now use your link.
I know you people all help in this forum for free and that one should be patient getting help but if I had gotten the correct version link when I first posted I would not have been in the total mess I got in.
Meanwhile I have a number of other questions. Can I bother you with them? Should I make new posts about it?
I will give a short overview:
Since a while I have problems with Full Scan. I have posted about this somewhere here a while ago. It just runs for hours and hours. I normally ran it once a week. Some weeks ago I thought the reason for this might be my I partition where I keep Acronis Images of my system. So I made a new Scan for only C,D and P. This runs well and takes only some 30 minutes. But it also gave a list of Malware (see attachment Comodo 4) strangely 4 of the files are about Dell Update that surely should be safe. I tried sending all the mentioned files using advanced tasks. 2 of the Dell update files got send. A third not. But I cannot find a Map Windows/Installer on C. Comodo finds 4 files there that are flagged as Malware.
And then there is the list of Containment events. I never saw anything there before but my guess is this is because I re-installed Comodo yesterday and it has been checking all the started programs again. What I find strange is that lots of “Trusted” programs are placed in the container. And what happens happens where I see Action “genegeerd” (I know you are Dutch too)
I have been looking at the logs a lot because I have an issue that I cannot explain:
I have been running Winaero Tweaker for years and use it mainly to stop and start Windows Update. This permits me to run Windows Update at a moment that is convenient for me. At this moment Winaero Tweaker is set to stop Windows Update but Windows Update keeps running.

And Eric - I have posted in the other thread also because I am confused about the uninstalling process and it seems I better post that there.

BTW - I just found out that my problem with Winaero Tweaker is not caused by Comodo. Seems the program does not work on the latest Windows 10 build

I am just a Comodo user for 20 years but have just had the most horrific experience with Comodo 6914.
There is a problem with this build.
Maybe it would be best to uninstall it and install the last stable build.
This is the thread with my problems https://forums.comodo.com/install-setup-configuration-help-cis/my-laptop-hangs-and-reliability-history-says-cavwpexe-does-not-work-anymore-t125333.0.html;msg894970#msg894970
EricJH gives the stable build in his post.

Hello danyb,

I can understand your problem sorry for the inconvenience after the stable release you won’t have this kind of problem.

Note: While Installing the CIS kindly use the latest Comodo Uninstaller Tool (Select upon your windows bit) for the clean Uninstallation of the CIS and then Install CIS.

Best Regards,
PD

Thank you Dharshu.
My problem is solved but I still have some questions on detected Malware that have not been answered yet.
The problem is that I get no notifications when someone answers my posts and so I need to come and look here every day.
So I try to help people that might have the same issues as me with 6914.

Hello danyb,

Could you please elaborate? Like what kind of Malware detected and follow this format?

  1. What you did?
  2. What you actually saw?
  3. What you expected to happen or see?and if possible with Screenshot.

Are you still facing this issue?

Best Regards,
PD

Could you please elaborate? Like what kind of Malware detected and follow this format?
  1. What you did?
  2. What you actually saw?
  3. What you expected to happen or see?and if possible with Screenshot.

Sorry I can not get you any screenshots anymore. I thought I posted them in reply 9 here:https://forums.comodo.com/install-setup-configuration-help-cis/my-laptop-hangs-and-reliability-history-says-cavwpexe-does-not-work-anymore-t125333.0.html;msg894965#msg894965 but I do not see them.

What I saw was some things to do with Dell Update and some folders that I could not find on the pc.

I unblocked everything with the help of someone from Comodo.

But I must say that I have issues with my Dell update lately

Hello danyb,

Thank you,if you still have any issues in future please feel free to contact us.

Kind Regards,
PD