My internet connection is blocked by Comodo!?

I have Windows 7 Ultimate 32-bit. I installed CIS with Firewall and all that, and it asked me to restart so I did. When my computer booted back up Comodo opened and showed the green arrow that it was running. My Ethernet icon showed a yellow ! Comodo had blocked my internet connection fully. I tried changing the settings on the firewall and everything. I then un-installed it and rebooted my computer. Still nothing! I didn’t install the Comodo DNS, as i use open dns. I searched for the drivers and nothing, i tried the IPV4 settings set on the connection and changed the ip, submask, gateway, and changed the dns settings… It then got a connection, sorta… I was able to ping IP’s but then when I opened up Google Chrome it showed connection refused… I now can’t get anything… I’m using a Virtual Machine right now on the same computer bridged network and the VM works fine…
Additional Details
Not even localhost works!! i tried re-installing the drivers to my ethernet card and everything… I can’t get a connection on my wifi either… same issue…
Windows 7 Ultimate 32-bit
ADSL connection Modem/Router
Avira Persona Free AV
Comodo (CIS + FireWall) << Cause!
– Currently Getting Twitpic
I have to use a VM to be able to get online…

Hey and warm welcome to comodo forums!

add your router’s ip address in the firewall by going to CIS → firewall → Stealth Port Wizard → define a new trusted network → I would like to trust and add it (the second option where you ca type in ip address)

I hope this will help.

Valentin N

Nope… It didn’t work when I had it installed. I have it un-installed now. And my connection is still ■■■■■■■ up…

add then the drivers to Application rules.

could you make a screenshot of your dns settings so that comodo’s dns is not active? (if you don’t know go to start → start → control panel → Network and internet → the very first option (I use a swedish OS) → click on the active ethernet → Activity → Properties → TCP/IPv4 → properties → obtain automatice DNS-server)

Could you also make a screenshot your firewall logs, networks, and Global rules

Valentin N

Here are a few snapshots i have tooken… More coming, if you need… I’m not totally mad, I just want my internet connection back… Comodo works fine on this VM i’m currently on… But apparently not my regular windows 7 comp. :confused:

[attachment deleted by admin]

do you know the ip address to your router? if you do, add in DNS primary(the first option) and see if that will help. Make also sure that the router accepts your pc.

Could you tell me if you bios has firewall? Nvida had (don’t know if the firewall is still there on nvida chipped motherboards)

Would you do the following, please.

Open a command prompt and type ipconfig /all - post the results here.

At the same command prompt type ping - post the results here.

At the same command prompt type ping (enter the name of your computer) - post results here.

If you have a router:

At the same command prompt type ping (insert the routers ip address) - post the results here.

I encountered this problem as well. I’ve managed to fix it by the following: Open Comodo preferences > Firewall > Define a New Trusted Application > Click on the Select box and choose either Running Process or Browse to find your Browser (if it is Google Chrome, go to your desktop and select it). Refresh your web pages to reconnect to the Internet. It worked for me. Take care!!!

- YouTube << All you above, I have made a video making it a little more clear… Please watch, and reply. :slight_smile:

A couple of things I noticed. When you ‘pinged’ your PC by name it returned the link ipv6 local address, whereas it should return the ipv6 equivalent of (localhost) which is ::1:

Also, when you set the option to obtain an address and other associated information automatically, you’re getting an APIPA address (169.254…) Addresses from this range are typically allocated when a DHCP server cannot be contacted.

The fact you can get the correct from a bridged VM would seem to indicate the router is doing what it should, so right now I’d suspect a borked IP stack. To test this theory, open a command prompt and type:

netsh int ip reset c:\reset.txt - Restart your PC

See what happens. You can also post the file here, but zip it first.

ok. I typed that in and it said OK on everything, it asked me to reboot my computer. I did. And I looked on my C drive and I see no .txt file that you were wanting… Also the problem isn’t resolved…

Ok, next is to try netsh winsock reset. It’s possible it’s a borked LSP.

If that doesn’t work, please set your adapter to obtain ip and dns settings automatically and post a screen shot here.

yea… I’ve seen that command on a website and tried it and got nothing… So yea… I’ll get the screenshot…

I didn’t set the DNS settings auto because I want it to be on OpenDNS…

[attachment deleted by admin]

There’s a lot of information missing on that screen shot, which should be there. For example, it’s not displaying your forced DNS servers.

You mentioned in an earlier post that you reinstalled the device drivers for your LAN card, did you check device manager for any problems?

It may also be worth running the Clean-up tool for Comodo Internet Security assuming you haven’t already. I guess it’s always possible some left over remnant may be the cause.

You also mentioned you’re not able to get a connection via WiFi, which is curious. Do you get a signal or is there nothing at all? Have you checked the router for ant MAC restrictions?

Finally, are you using any other security packages and what happens if you close the VM and try an ipconfig /release followed by and ipconfig /renew?

That pretty much defies the whole firewall purpose, doesn’t it? If there’s anything that should NOT be trusted and have only tight standard ports open it’s the web browser.

Either may be configured in the firewall. For novice users, simple, predefined rules can be allocated to specific types of application. For example, the default browser rule allows connections for TCP out on port 80, 443 and 8080. It also allows for DNS queries and FTP. For more technical users, it’s easy enough to make modifications.

For some users, the simplest method of getting something working, is to make it a trusted application. That’s a matter of personal choice.

I ran the clean up tool, everything… I’m getting mad now… I can’t believe such a program caused such disaster… This computer means alot to me and I’m basically dieing inside because I’ve been offline on everything and time is passing by… I’ll try anything you guys suggest… Comodo did something deep… I can feel it… And I really don’t wanna have to re-install my OS again… As i worked so hard to set everything up… If you need screenshots, anything… lettme know… Cuz I want this fixed… Everything you said I tried and did not work… :expressionless:

Can you check in Control Panel to see if the Windows firewall is enabled.

If you do not mind me asking, what version of CIS did you install, I know CIS 3.5 (over 2 years old) had this problem of breaking internet connections…

If you did install 3.5 please do tell us where you download it from… so it can be updated.

Thank you.