My experience with CTM (Linux as second OS and Truecrypt)

Well… Some days ago I’ve started to make anything to install CTM. I have two TrueCrypt partitions and Linux in another (Kubuntu 10.04). The CTM installer was blocked three times:

  1. Multiply devices (or disks, I can’t remember, although I’m in a notebook with just one harddisk…).
  2. Truecrypt installed.
  3. And then Linux is detected in the last partition…

How I manage it:

  1. Remove attached devices… although does not seem to be a problem.
  2. Uninstalled Truecrypt but does not boot.
  3. Hide Linux and Truecrypt partitions with a partition manager tool.
  4. Install CTM successfully.

Then, booting…

  1. First I got a BSOD (probably the conflict with Truecrypt driver? 0x0000007B (0x80786B58, 0xC0000034, 0x00000000, 0x00000000).
  2. Uninistalled CTM by the console.
  3. Windows 7 boots normally and CTM finished the uninstallation.

Installing CTM again and booting worked without a BSOD.
Then I could install Truecrypt, it worked and does not conflict. I’m not protecting the TrueCrypt partitions into CTM, of course.

Tried to boot Linux in the hidden partition formated as Ext4 (using the Windows 7 boot loader + EasyBCD) I found the following:

  1. Kubuntu entry in Windows 7 boot loader (/dev/sda9 or (hd0,8)) fails (file not found).
  2. Kubuntu grubless in Windows 7 boot loader works, but I can’t boot the normal way, just the Recovery Mode.
    I’m not sure if the problem is being the partition hidden or there is any problem in Linux (as I’m not an expert with Linux).

So, I’m not sure it’s a dangerous situation but you could have Linux as a second OS (if it was installed before CTM and probably using Windows 7 boot loader with GRUB not installed in the master) and TrueCrypt (if it is installed after CTM and with its partitions not protected by CTM).

Happy CTM user :slight_smile:

Is CTM compatible with wubi (Ubuntu into Windows)?

Yes, CTM is compatible with wubi. But if boot into Ubuntu with wubi , please do not access the partitions which protected by CTM, otherwise you may lost some data even broken the windows .

Access, do you mean “mount” the partition?
Can I install wubi into C:\ubuntu if it is protected by CTM?

Well, the computer frozen three times.
I’m enabling the manual dump on crash.
Is there anybody on Comodo team that could analyze dump files?
Is there a ftp site to upload the dump?

I hate freezing… It seems difficult to troubleshoot. It’s not like a conflict and BSOD ;D

Computer is asking me to run chkdsk each boot. How can solve this?
Is there a way to run it within CTM?

CTM intercepts all disk access to all protected partitions. CTM will only run under windows. It will not run in ubunto. This means that if umbunto is the active OS, then CTM will not intercept the disk access to the protected drives and the disks writes done by umbunto will altter the drive content of your “protected” drives without CTM knowing about it. Next time you boot into windows, then chkdsk will detect problems, as you already experienced. I don’t think that CTM can solve this, though i might be out of order here.

Thanks marlonvdb. The point is that I do not have Ubuntu (or wubi) installed anymore. I’ve deleted the Linux partition, resize the others, then install CTM. I’ve reset the baseline once, I’ve scheduled a chkdsk once (I don’t know this will be a problem…). But now, each boot, chkdsk is invoked. What can I do ???

Is there any way to solve the NTFS structure troubles that I know is happening?
Running chkdsk within Windows without the parameter /F (i.e., running read-only).

There are:

  1. Corruption in the files registry.
  2. Orphaned items.

Is the only solution to uninstall CTM? :frowning:

[attachment deleted by admin]

The computer freeze but I can’t dump… The file is not written to the disk as CTM is not available at that time…
It’s difficult to work with this constant freezing.
I will uninstall CTM.

A corrupted file structure problem like that can only be solved when windows is not active. Also chkdsk can only repair it before windows is loaded. The problem is that CTM is not yet in the air at that point. Each change to the file structure that is done without CTM knowing about it will mostly cause more problems. There are tools available that can repair the file structure (there are some useful tools on hirens bootcd), but most of them run from windows PE bootcd’s, meaning CTM is not in the air and any disk change will probably ony make things worse. I think you indeed need to uninstall CTM first before you try to repair your file structure, but the question is if the uninstall will work. Your file structure is damaged, so maybe also will your CTM snapshots be damaged. Does CTM not use at least the “current” snapshot during uninstall?

My suggestion is to 1st make a sector based image of your complete hard drive. That will take some time which enables you to look up the windows setup cd, cos you might end up having to reinstall windows.

Maybe someone of the CTM development team can give you better advice, so please wait at least for a reply from them before taking actions. I did notice that they are quite active on this forum for the last few days, thus maybe by tomorrow you can have there advice.

Uninstallation done the job. I’ve run chkdsk twice, then defragment, then reinstall CTM.

Wow… It does not go so worse. Thanks God.

No, you can not do this.
Marlonvdb, thanks a lot, you have explained very clearly.

I guess so. My way is VirtualBox now…

Some people do have all the luck :wink: