my COMODO can't running

I installed COMODO firewall,when i reset my computer,COMODO show follow messages:
“the comodo network monitor is not active.reinstalling the application may fix the problem.”
Have more messages in uploaded file.
please help me! thank you.

[attachment deleted by admin]

A couple possibilities here, gonden:

  1. You’re using an unsupported OS (either Vista or a 64Bit platform)
  2. There was a conflict during install of CFP - this can come from remnants of an old firewall, or some active security application (like antivirus, antispyware) that was left on during the installation process.

LM

There’s a third possibility that it will be fixed in V3: https://forums.comodo.com/index.php/topic,7034.0.html

A few weeks back, comodo updated itself and ever since it has not worked. I have tried uninstall and reinstall, I have even downloaded the manual uninstall utility and tried that. Every time I launch the firewall (on windows startup) I get the message: The Comodo Application Monitor is not active. It suggests a reinstall may fix this. It doesn’t. If I double click the Comodo icon, I see that Protection Strength is poort because the Application and Component monitors and the Application Behavior Analysis modules are off. But I cannot turn them on. And if I go into the Application and Component monitors, I cannot even add rules.

I would love to hear any suggestions on how to turn the firewall back on…

thanks

matt

I searched everywhere for this topic, couldnt find anything similar, then as soon as I posted, saw a number of similar requests. I was about to delete my post when i saw you moved it…thanks.

etherm,

When you uninstalled CFP, is there any possibility that you ran a registry cleaner (or did a manual sweep), prior to reinstalling?

Also, when you have installed, did you have an active security software running (AV, antispyware, HIPS), or any sort of “real-time,” “active-shield,” etc software?

LM

When nothing else worked I tried using CCleaner, but it didn’t seem to find anything related. I had msft defender installed for a while but tried uninstalling it when comodo wouldn’t install, but it seemed to have no effect. There are no other tools installed (AV, spyware detection, fw, etc).

etherm,

Presuming that you don’t have CFP installed right now, do the following:

  1. Download a new, current installation package: http://www.personalfirewall.comodo.com/. don’t install yet.
  2. Go to Start/Run, type “msconfig”; go to the Startup tab, make sure there isn’t a checked entry for Comodo firewall; if there is, uncheck it and click Apply, then close. Don’t reboot yet.
  3. Go to Start/Run, type “services.msc”; look for Comodo Application Agent entry, change startup type to “Disabled.” Now Reboot.
  4. Go to Start/Run, type “devmgmt.msc”; then go to View/Show Hidden Devices. Find the section for NonPlugNPlay Drivers, and two entries for Comodo: Comodo Application Engine, Comodo Network Engine; Uninstall if present.
  5. Navigate to c:\program files\comodo\comodo firewall; make sure the folder is empty, or even gone entirely.
  6. Run a registry cleaner; I have found more thorough results using RegSeeker, over ccleaner. You can run it on Auto, or do a search for “Comodo,” “CFP” and “CPF” entries. Be sure to use the backup feature… :wink: Reboot following the registry cleaning.

Now you should be able to try a reinstall.

IF CFP is currently installed and misbehaving, prior to uninstalling, do the following (after repeating completing Step 1 from above):

  1. Change Security Level to Allow All.
  2. Go to Security/Advanced/Miscellaneous, uncheck the box “Protect own registry settings.” OK.
  3. Exit the firewall (from CFP’s systray context menu, select “Exit”)
  4. Repeat steps 2 and 3 from above
  5. Uninstall using CFP’s own uninstaller, available thru Start/All Programs/Comodo/Firewall/Uninstall.

LM

I tried everything you suggested, but there is no change in the results. Any other ideas?

You’ve got me there, etherm. It’s beyond the realm of possibilities in my little world, that that didn’t work. (:AGL)

Seriously, I don’t know why it wouldn’t work now. If you’ve gone thru the detailed uninstall/registry clean/reinstall process and it still doesn’t work, I must say, " ??? "

Will you file a ticket with Support: http://support.comodo.com/; provide them a link to this topic, and be sure to keep us updated on their response.

Sorry I don’t have a better answer for you. There must be something occurring at a deeper level in your system…

LM

Don’t make me repeat myself, mac. Fine. Let me link the direct one: https://forums.comodo.com/index.php/topic,6912.0.html

For the first, there isn’t a clear connection providing a resolution and promise of a fix…

For the second, that would appear to be a completely unrelated issue (multi-user logoff/firewall off)…

You seem to think I missed something; obviously I’m not getting what you think I’ve missed. Am I that much off my rocker? (:SAD)

LM

Yes.

You made me repeat myself:

I never stated it was a definite solution. If Comodo identified the disabled monitors after a log off/on then perhaps they’ve discovered the bug in general, no? But I do agree that it won’t hurt to file a ticket to describe the situation is different from the other one just in case.

Okay, good to know. ;D

FWIW, I can assure you I don’t want to get on your bad side, what with your anime avatar’s finger flyin’ around doin’ scary stuff. Might make my Komodo dragon avatar shiver.

LM

Oh they can run, alright. Quite fast. Perhaps that is why I don’t have this issue myself. :wink:

LM

PS: Now stop hijacking the thread! Be a good Mod; set a good example! For shame, for shame. Don’t make Melih warm up his SMITE key…

I thought I should post an update. I contacted support. Within a few days I got a response:

Thanks for your interest on our product,

Sorry for the inconvenience caused to you.
Please un-install the comodo firewall pro in your system Confirm the following: after un-installation

  1. You do not have traces Comodo Firewall installed in your system, please check if there are files from previous version.
  2. Please check if following registry entry exists in your registry:
    “HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall”

Should have any queries donot hesitate to write to us.

Yes, that was it. My response to them was that I tried that and asked if they had any other suggestions. I have yet to hear any more from them.

I have done a search for every reference of Comodo, CFP, and CPF in the registry. There is nothing. I have no other spyware system installed. There is no AV software installed. There had been both, but they are completely uninstalled. But every time I reinstall CPF it tells me that the Application Monitor is not active and that a reinstall may solve the problem. I can’t believe I am spending so much time trying to solve this problem even though no matter what I try nothing ever changes. Any ideas?

etherm, sorry to see they didn’t resolve this. Did you remember to link them to this thread for reference to avoid asking you the same questions?

Have a look at my post yesterday about installation problems:
https://forums.comodo.com/index.php/topic,7617.msg55604.html#msg55604

One of the links has Pandlouk’s Uninstaller.

Yes, included the link in the message to support, but I don’t think they looked at it. Here is the original message to support:


I have been using the forums to try to troubleshoot this issue(https://forums.comodo.com/index.php/topic,7186.0.html), but they suggested I submit a ticket since they can’t figure it out.

the Firewall product was working just fine until an update was released a month or two ago. When Comodo updated itself, it stopped working. Double-clicking the Comodo Firewall icon in the System Tray shows that Network Monitor is on, but the other three items are off. I cannot turn them on. I have uninstalled/reinstalled many times, sometimes using registry cleaners to clean out what comodo left behind and I still cannot get this to work. I am on Windows XP SP2. There are no AV tools running, and no other antiSpam, etc tools running either. I am a local administrator on this machine.

As a former PM and TS at Microsoft and many other software companies, I am pretty familiar with installing software, but I cannot get this to install correctly. I would love to hear any suggestions you may have to get this working.

I had tried pandlouks uninstaller before but tried it again. The last few uninstall cycles have been:

1)Use Pandlouks uninstaller
2 reboot
3 Follow the procedures in Little Macs post on March 19
4 reboot
5 Use Pandlouks uninstalled again
6 reboot
7 again search for any reference of Comodo, cfp or cpf in the registry
8 reboot
9 install

Same results. I tried it again using the Add/Remove programs uninstall first then all those steps. Same results.

Is there a log file that gets created on install and use? Is there a way to turn one on??

etherm, we know you are quite familiar with uninstallation procedures and the registry, so it has to be some other software/driver conflict that’s preventing CFP’s driver cmdmon.sys from loading…and we also know you’re not the only user with this problem. If you access Windows Services, is the Comodo Application Agent up and running? Did you install it on the default C: drive and path?

As you can see, there has yet to be an official resolution from these threads:
https://forums.comodo.com/index.php/topic,6399.0.html
https://forums.comodo.com/index.php/topic,5653.0.html
https://forums.comodo.com/index.php/topic,6739.0.html
https://forums.comodo.com/index.php/topic,5458.0.html

There may be an install log, but it may only be temporary. Few places to look:
C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall
C:\Documents and Settings[b]your username[/b]\Application Data\Comodo
C:\Documents and Settings[b]your username[/b]\Local Settings\Application Data\Comodo\Comodo Firewall
C:\Documents and Settings[b]your username[/b]\Local Settings\Temp (and of course this one, where the temporary files are stored)