msi to exe converted

:wink:

I have upped a 32bit msi converted to exe.

It installs and runs fine for me on a windows XP Pro SP3 machine (the msi worked on this machine too, hence this caveat)
So if Sorcerer and whoever else, would let me know if this trivial conversion sorts out your problems.
It would be appreciated :slight_smile:

Edit killed link.

Bad

Bad Frogger,

Thanks for the EXE version of V4 Beta. I download it and try to install. But roll back again.

I think the kernal is still using MS MSI functionality. My PC appear the same “msiexec.exe error” “want to report to issue? Yes?” “No”

I report it, but don’t know how to handle it.

WinBMY

I also used a converter and had the same problem as WinBMY, nothing doing even after manually removing all instances of CIS V3 thru Regedit it just won’t install it creates desktop shortcut but rolls back right at the kernel driver install attempt, I’m lost on this one. CIS V3 installs flawlessly.
Sorcerer

Did you try to update Windows Installer ?

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=5a58b56f-60b6-4412-95b9-54d056d6f9f4

Updated on the 16th Jan/2010, still no go :frowning:
Sorcerer

[attachment deleted by admin]

Sorry guys :frowning:

I guess I’ll kill the link.

I notice that on my XP Pro SP3 box the msiexec.exe and the msi.dll in the system32 folder are version 3.1.4001.5512

Have you guys tried the msicuu2.exe (microsoft installer cleanup utility), perhaps you have some leftover bad entry from some previous install of something.
http://support.microsoft.com/kb/290301
Use care and only remove entries for software you know you have uninstalled.

Then follow with a registry clean with Regseeker http://www.hoverdesk.net/freeware.htm
It’s old but so is our OS in this case. Make sure to save a backup when it offers before deletion.

I had msi problems several years ago, can’t remember any specifics though.
Perhaps we can sort this out through comparisons.

Later

It turns out that on my system I’ve got MSI v3.1.4001.5512 as well. I remember updating Windows Installer to version 4.x but I must have format PC after that. Anyway, I thought Windows Update will automatically include Windows Installer 4.x in High Priority updates, but as it seems it’s neither in High Priority nor in Optional updates for Windows XP SP3.
With MSI v3.1.4001.5512 I didn’t have any problems installing last two betas of CISv4.

Perhaps the issue lie elsewhere. I installed Windows Installer 4.5 on XP SP3 and CIS msi installer worked fine.

update windows installer to 4.5, do windows installer cleanup, then clear registry by Regseeker.

I got new error message: “Windows Installer發生錯誤” (English might be Windows Installer Error)

Original error message was “msiexec.exe 發生錯誤” (English might be msiexec.exe error)

I bet if you reformatted this problem would be gone. In the longer term this might save time versus trying to investigate the intricate details. Any change in M$ system files or registry are the worst to troubleshoot. This is just my based on my experience.

Read here: https://forums.comodo.com/feedbackcommentsannouncementsnews-cis/straight-answer-to-a-simple-question-t50927.0.html;msg367753#msg367753
Reformatting is not an option nor desired if other MSI packages install correctly IMHO
Sorcerer

MSI issue solved by adopting new CIS Installer (RC version)