MS Visual C++ Runtime Library error dialog in session 0 [Issue Report]

I sometimes get an error message in session 0

“Microsoft Visual C++ Runtime Library
Runtime errror
c:…” ← It doesn’t provide me with a path just 3 dots

I can’t take a screenshot of it because that doesn’t work in session 0 apparently.

See my thread:

The bug/issue

  1. What you did:
    It occurs randomly
  2. What actually happened or you actually saw:
    A dialog box from windows telling me i have a message in session 0.
  3. What you expected to happen or see:
    Not applicable.
  4. How you tried to fix it & what happened:
    I can’t fix it without the source code.
  5. If its an application compatibility problem have you tried the application fixes here?:
    Not applicable.
  6. Details & exact version of any application (execpt CIS) involved with download link:
    Not applicable.
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Not applicable.
  8. Any other information (eg your guess regarding the cause, with reasons):
    This is a programmer mistake.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
    Session 0 doesn’t allow screenshots.
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
    Not applicable.
  3. A CIS config report or file.
  4. Crash or freeze dump file:
    I’ll add a freeze dump the next time this happens.
    I’ll add a process explorer’ handles view screenshot too the next time this happens.
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:
    CIS version 5.5.195786.1383
    AV database version 9606
    Configuration: “COMODO - Internet Security”

  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
    Clean install

  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    Not that i can remember.

  5. Defense+, Sandbox, Firewall & AV security levels:
    D+=Safe Mode
    Firewall = Safe Mode
    AV = Disabled

  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 service pack 1 (64-bit)
    UAC setting: default
    account type: default

  7. Other security and utility software installed:

  8. Virtual machine used (Please do NOT use Virtual box):

[attachment deleted by admin]

Here’s a full dump of cmdagent when that message is shown. Dump made by process explorer.

[b]Exiting cfp.exe by right clicking menu ‘exit’ in notification area and then start comodo again will NOT restart cmdagent.exe.
Only thing that work is a reboot !
That is a MAJOR flaw.

A programmer should never assume it’s program never crashes
Comodo should detect that cmdagent isn’t running and start it if necessary[/b]

[attachment deleted by admin]

Thank you for your Issue report.

Moved to verified.

Thank you


You can thank me by fixing this serious bug :cry: sometime this year would be nice 88)

I can confirm this bug happens when there’s 0 bytes free space left on the hard drive.
I can also confirm this didn’t happen before.

Now can you PLEASE fix this very serious crash bug ? >:(

The only workaround is a restart.
Restarting comodo doesn’t work.
Ignoring the message doesn’t work because this bug causes a block on the kernel (why its a serious bug) which will build up until the system just stops works at all, not hung / freezed but as if it’s waiting for something, which it is the comodo kernel driver.

I’d be glad to fix it for you, if you are incapable of doing it yourself, just to get this very annoying bug out of my life. Just send the needed files.

Getting a bigger hard driver isn’t a solution, its a workaround 88)

A crash is a serious bug no matter what caused it. Especially when its a kernel driver !

Sorry nothing to do with me I have no knowledge or feedback from Staff members most active Moderators are not Staff members.

Any feedback if any is done usually by PM’s direct to the member who submitted the bug/issue report.

Sorry I cannot help.


Please note all Staff members will have a Staff avatar.