Mozilla Firefox: "Certain sites don't show fonts" problem

There are times when Mozilla Firefox would fail to display fonts, specifically fonts over white background, properly.

Sites where this would happen include Wikipedia, and the Firefox add-on website (especially the Firefox add-on website, whereas wikipedia would not always fail to display fonts).

Can anyone shed some light about this?

My anti-virus is the latest avast (free version).

For spy and malware I have Spybot -Search & Destroy, Spyware Blaster, and Malawarebytes. I don’t use these 3 much, hence I only updated them when I use them.

I also have Comodo Firewall v4.1.150349.920.

Below are the screenshots. Its pretty big. Its actually an entire report already. Hope it gives you a better picture. This issue is really annoying because I don’t encounter the “problem” using other PCs using Mozilla Firefox even if I meet the certain “conditions” that will result in the problem.

Oh, and I have the latest Firefox, 3.6. Updating Firefox hasn’t helped so far since I have been encountering this “problem” since a few versions of Firefox ago.

If the pic fails to load, here’s the link.

Do you have any extensions installed?
Do you have same problem with a clean profile?

Define extensions. I may have, but am not sure.

How do I do a clean profile?

Checks online what “Firefox extension” means.

Yes, yes I have. Here it is.

How do I do a clean profile?

Something like this. :slight_smile:
Your extensions looks harmless but it’s better to diagnose on a clean profile.
Also latest java 6 update 21 should be installed. It’s good to have latest Java JRE.

I have tried Firefox in SafeMode. Still encountered the same problem. What do I do with the other Java add-ons that I have?

I have tried using a clean profile as you instructed through the link you gave.

Unfortunately, still encounters the same problem.

maybe a reinstall is necessary cuse if its still doing it on a clean profile maybe there is something wrong with the installation

I’ve already done that. Fresh install from a fresh download of Firefox 3.6.6. Same exact problem encountered. And I found out that this happens regardless of what search engine I use too.

I didn’t delete personal stuffs though like bookmarks and customizations.