Move/Delete log file has a bug in the log OR its setting [M1793]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
It’s always present, even on older version of Comodo.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:In this setting window Logging of Events, Log Management, Event Log Management | Comodo Internet Security choose the option “move it to”
2:see in “Configuration Changes” in CIS Logs the new entry
One or two sentences explaining what actually happened:
It says (at least in the Italian version, and now translated) in the “Old value” > “move it to…” and in “new value” > “delete it”
One or two sentences explaining what you expected to happen:
Now I don’t know if the values in the Log are simply swapped (therefore a GUI bug) or the option in Logging settings are actually swapped (so if you choose to move it, it will actually be deleted), but it needs coherence.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Doesn’t matter
Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Between major version I always did a clean install and this bug exists since quite long ago if I recall correctly. Between minor version I always do and upgrade.
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 8.1 x64, UAC default, Admin, no VM
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

[attachment deleted by admin]

Can you please attach your active process list from killswitch and the diagnostic report from CIS? So that I can send this to the devs thanks.


Thanks and just to let you know, fortunately this is just a GUI bug in the log viewer as I tested the behavior when the log is full, it does indeed get moved to the folder you specify. So moving to Verified thank you for the report.

This is fixed with the CIS public beta v10 moving to resolved.