Mouse won't get detected by PC

In my gaming PC, I can’t seem to get my mouse detected as “HID-compliant mouse.” It gets detected as “HID-compliant device”.

If you click on Control Panel → Mouse → Hardware, the box is empty.

Here’s the rundown of events:

I had an old ps/2 mouse, 800dpi. Its the kind that you plug into its exclusive green colored ps/2 port. That mouse had malfunction issues which I tolerated for years until this week. I left it in an electronics recycling bin.

That meant that my gaming PC didn’t have a mouse for some time. Then I decided to try and get my laptop mouse, a Logitech M-UAG120, to work on my gaming PC.

Sounds like a straight-forward thing to do, just plug and play. Lo and behold, plug and play didn’t work. I had to do some things in Control Panel → System → Device Manager to get it to work. It got detected as HID-compliant mouse.

But I did got it to work. And this afternoon, I played games with it on my gaming PC. Then I decided to buy a new mouse. A LEXMA AM546 Laser mouse.

Both Logitech and LEXMA mouse are usb.

I only got the Lexma to work for a second, and only after I tried to plug it in all the usb ports of my gaming PC. And now it seems that even the Logitech mouse won’t work anymore in my gaming PC.

Both devices are detected in my gaming PC as “HID-compliant devices” and not “HID-compliant mouse.”

If you click on Control Panel → Mouse → Hardware, the box is empty.

I can’t even specify specifically what kind of HID-compliant device they are. I can’t “Add New Hardware” since “HID-compliant mouse” will not appear in the list of devices. There are no conflicts, no “!” in Device Manager.

Note also that that is not the case in my laptop. Both mice can even be used on my laptop at the same time. The Logitech even gets detected as a Logitech HID-compliant Tilt wheel mouse. The LEXMA, for some reason, is dependent on the generic Microsoft mouse driver. It does not seem to have a driver of its own, even with the software CD that came with it labelled “driver”. And the LEXMA website offers no driver for the LEXMA AM546.

It sounds like there may be something wrong with the USB port of your desktop. What does device manager tell about your USB hubs and ports?

Its says its fine.

In fact, so long as it is not a mouse, it gets detected.

Heck, my very old usb keyboard gets detected and installed quickly in any of the usb ports

Make sure that in the BIOS it is set to accept all USB including legacy USB. It’s just a guess.

How old is your motherboard? What year is it from and what brand and model is it? Is there a BIOS update available for it?

My motherboard is brand new. It is one of the newer models. My BIOS is set up to accept all including legacy USB. I haven’t updated the BIOS itself, but I have updated the chipset.

If you can, take time to read the thread I posted in another forum detailing this problem.;tracked-disc

I will also paste some essentials from that thread here:

Mouse issues
by Phil Crase - 10/8/09 7:27 AM In reply to: Already tried that. by VicGI

What OS? Sounds like a system issue, corrupted or missing driver(s). Do OTHER USB devices work normally?

usb mouse won’t get detected…
by VicGI - 10/8/09 8:46 AM In reply to: Mouse issues by Phil Crase

OS is WINXP Professional SP3

Yes, each and every other usb device works fine and proper…all except the mouse, as in neither one of my usb mouse works.

I’ve been observing the auto-detection behavior of WINXP under Control Panel → System ->Hardware → Device Manager.

In Device Manager, I notice that, if I remove the USB Keyboard from its usb port, the Device Manager entry, “Keyboards” (with the + or - box beside it) disappears together with some sub-entries under the Human Interface Devices. If I plug the usb keyboard back into the usb port, the sub-entries that disappeared under the “Human Interface Devices” entry reappears as well as the entry “Keyboard.”

If I insert the mouse into the usb port, under the “Human Interface Device” entry an extra “HID-compliant device” sub-entry is automatically added, and the mouse itself gets detected as “USB Human Interface Device.”
The entry, “Mice and other pointing devices” does not automatically get added to the list of devices. In fact it never gets added at all, and I tried to do it manually through Control Panel’s “Add New Hardware”, to no avail. (This is not the case with my laptop. With my laptop, heck I can even use both mice, as well as my WACOM graphire tablet, all at the same time)

Gah! If only there is a way to add the entry “Mice and other pointing devices” manually. Plug and Play my hairy booty!

Like I said, the mouse only gets detected under Device Manager entry “Human Interface Devices”. It’s there as a sub-entry “USB Human Interface Device” and an extra “HID-compliant device” sub-entry gets added as well. And if you check the newly added “USB Human Interface Device” sub-entry, it actually even detects what kind of mouse it is:

Device Type: Human Interface Devices
Manufacturer: (Standard system devices)
Location: Location 0 (Logitech USB Optical Mouse)

If I plug in both of my usb mice, they both get detected as “USB Human Interface Device” specifically identified what kind of mouse, and two extra “HID-compliant devices” sub-entry gets added as well.

But the thing is, they never get detected as “Mice and other pointing devices.”

I think that is the crux of the matter.

NOTE: I was able to make the Logitech mouse work twice now. I really don’t know what happened. It just got detected, and the “Mice and other pointing devices” entry got added and actually stayed there in the Device Manager list. But in trying to make my new LEXMA mouse to work on my PC, I kinda lost the two lucky breaks I got with the Logitech mouse.

I got the LEXMA mouse to work at least 1 second though. And there were times too when the Logitech mouse got detected for 1 second, and I saw the entry “Mice and other pointing devices” get added to Device Manager, only to disappear a millisecond later.

I hope this update helps.

I forgot to add:

My overall system details:

OS: WinXP Pro SP3 (32bit)
RAM: 4GB with only 3GB usable due to WinXP being 32bit
CPU: Intel Core2 DUO E8400 3.00GHz
Motherboard: ASUS P5Q SE2
Video Card: nVIDIA GTX295
PowerSupply: HEC Cougar 1Kwatt.

I have a mouse which also registers as HID Compliant Device under Human Interface devices. It also register as USB input device, It does not register as mouse

I looked up your motherboard. There is no BIOS update for this problem. Since Windows does recognise the device I think the problem may be with the motherboard. My advice would be to go to ASUS support and check their forums or when possible open a support ticket.

A support ticket?

Also, since you have the same mouse problem I have, have you solved yours?

If so, how?

Was it really just a BIOS update in your case?

Also, I was advised by the founder/administrator of this:

[b]Re: Mouse won’t get detected by PC

If still no joy try this:

  1. Browse to the folder C:\Windows\inf and find the file INFCACHE.1 .

  2. Rename the file INFCACHE.1 to INFCACHE.1.BAK.

  3. Reboot[/b]

Is this advisable? I mean is it okay for me to just rename a file? What if it doesn’t work?

My mouse gets registered with no problem on my XP, Vista SP2 and Windows 7. My advice is just generic troubleshooting to see if it could be a hardware issue. The latter is my hunch for now.

I have no idea what would happen when doing as advised by the founder/administrator of To be on the safe side of things make a System Restore point before doing this. Also remember in case Windows would not boot to use Last Known Good Configuration. In the unlikely case your installation would get hosed and could not enter Windows then follow this rescue tutorial: .

Vista’s got SP2 already?

I thought only XP’s got SP2 (and SP3).

There is SP 2 for Vista but the timing of deploying it by Windows Update differs depending what country you are from. Run Windows Update to see if it is there or not.

However there is the off line version for all languages to be had from Microsoft: .