(MORE 1603 Errors) preventing any installation on 64bit versions

I am writing in regards to an error that prevents me from installing Comodo at all. I have posted repeatedly on this issue, with all the details and am at a loss. This has happened with (from what I remember) 4.0, 4.5 (I think, there was a 4.5), and I know for sure 5.0, 5.1, 5.4, 5.5, 5.8, and now 5.9.

My old 32bit XP box is fine with the upgrades, and the issues lies on my 64bit Win7 laptop. I know the same installer has been used (the 32bit/64bit combo installer), though in earlier versions, the appropriate installer was used for the OS “type” (32bit or 64bit) … the error is the (I forgot the exact message) Error 1603, related to the CAVShell.* file.

I am just trying to install the Firewall (and defense+) and NOT THE COMODO AV, browser, or any other bundled items (the fact the installer comes with all of these extra items is another comment of mine … but not for this post)

Up until 5.5, I was able (64bit PC… the one with the issue) up until 5.5, when I saw the error, hit the power button, rebooting the computer (in “mid install”) and the Comodo would be installed, with errors … THEN I opened Comodo, and go to where it says “Diagnose Problems”. and I would scan for issues, it would find and repair errors, I’d then reboot again (normally) and Comodo would be a-OK.

the only additional issue is I’d have to prevent the installer from uninstalling on A) each reboot or B) every-time i run any MSI installer by going to (this tip was found on another site) " HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress" and remove (I again forgot what was listed there, but i think it is just the data key that shows " …comodoinstall.msi" or whatever the path was)

After multiple tries, Comodo (even with my method above) still doesn’t install. I am not “THIS PRODUCT STINKS” like some posters do; however, I am getting very frustrated by this constant problem. I know it COULD be on my end, and have tried everything (with the official .bat uninstallers, and all the other suggested options). I am unable to come up with why this keeps happening with ONLY Comodo (and never any other “installer”). For now, If I cant come up with a solution, I may be forced to (on the problematic 64bit PC) use I rival product. (note: I do not want to, but if its “use a rival product or no software firewall”… then I have no choice)… I will for now … continue to try to come up with a solution

Thank you for your time

oops … for the record, I am in a rush now and though i said “error 1603” … it could be “1608” … i really forgot … it always seems to be related to CAVShell.* … sorry about the numbering mixup

With CIS uninstalled did you try Windows Installer Clean Up utility.?

This tool cleans up all Windows installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed. Notice this tool does not uninstall a program.

Error 1603 is a Windows Installer error. As such, maybe you should Windows Installer logging to try and find out what’s happening.

OK now, (SOMEHOW) I managed to get the firewall installed, though unlike before “Run Diagnostics” can NOT fix these errors.

I am including the “log” of the install (with the - * log.txt command-line) AS WELL as the “log” created/saved when “Run Diagnostic” fails

I want to say how much i like this product, and I really wish I knew what was going on to help Comodo (and users who happen to have the same issue as me) fix this. I would hate to have change firewalls, when I am comfortable with Comodo.

[attachment deleted by admin]

Hello again, I have gotten it to work again via my “reboot when error comes up” and remove that registry key method, … so it’s not ideal, though it works … I uninstalled Avast and tried Comodo (Firewall + Defense+ … no AV) and it works again… if I have to remove Avast every Comodo Upgrade, its a pain in the ■■■■, but it beats the heck out of fighting with it for hours, trying to figure out wtf is going on … still having a 1603 error during install on the 64bit PC but at least i can actually get it uninstalled (“at all”) now


have it working for now, but the issue is not “solved” in my opinion… .not blaming Comodo entirely for this … just trying to find whats going on and how to fix it. the 32bit xp box upgrades just fine and always has