Mojo_system.dll Error with Google Chrome

Since CIS updated to v7.0.315459.4132, I have had an error stating that mojo_system.dll is missing and Google Chrome cannot start. Clicking ‘OK’ then allows Chrome to open normally. I have tried uninstalling then re-installing Chrome dev 35.0.1916.17 and still get the same error. I have attached a snip showing the chrome folder and the error message.

Can someone please investigate this ASAP as it is very very annoying not just for me but for other people too!


For Info:

Alienware M15x, i7 M620, 8Gb RAM, Radeon HD6570, Win 7 Ultimate x64 SP1

[attachment deleted by admin]

Please try disabling all protection components of CIS. Then restart the computer. After restarting see if the problem still occurs.

Let me know what you find. We will continue from there.


Disabled all CIS protection components, restarted laptop and tried opening Chrome. Received the same error.

I picked this up as I also have a clone of this system with Chrome updated but CIS not updated and NO error was seen on the clone. (I tried the clone due to this error - I thought that it may be a Windows problem but as the clone is basically this system with all updates, except CIS, installed and as a number of people have reported the same problem AFTER CIS was updated, it would point to CIS causing the problem)

Okay, I will now rule out installation/updating problems. Please reinstall CIS by following the advice I give in this post. Also, just before reinstalling it, please try and make sure that Google Chrome does not show an error after CIS is completely installed.

If it does not then reinstall CIS and let me know if the issue continues even after reinstalling it by following these methods.


I also posted this problem on the Chromium Forum and, after an observation by someone there, tried copying mojo_system.dll from c:\program files (x86)\google\application\35.0.1916.17 to c:\program files (x86)\google\application. I then ran Chrome with no error displayed. It would seem that a programming error in 35.0.1916.xx versions of Chrome leads it to check the wrong folder for mojo_system.dll. As the 35.0.1916.xx versions came out at the same time as CIS updated, everyone drew the wrong conclusion. So if you receive this error just copy mojo_system.dll to c:\program files (x86)\google\application!

Thanks for your assistance.

I’m glad to hear that this is now working. In that case I will move this report to Resolved.