modem will not renew ip address

Hi, I have the problem of the ip address not renewing on dhcp.
I found that the firewall rules could be the problem. I have some rules but need to make sure they are right.
Sorry I don’t know how to copy the rules here.

Ok, here’s the rules

0)permission: allow
protocol : ip out
source: any
destination: zone:D-link DFE 530tx- pci fast ethernet

  1.                allow
                     ip in
                     zone:D-link DFE 530tx- pci fast ethernet
                     any
    
  2.                  allow
                      tcp/udp out
                      any
                       any
    
  3.                  allow
                       icmp out
                       any
                        any
    
  4.                    allow
                         icmp in
                         any
                         any
    
  5.                      allow
                           icmp in
                           any
                            any
    
  6.                       allow
                            ip out
                             any
                             any
    
  7.                         block & log  
                              ip in/out
                               any
                                any
    

Hope this is good.
I also need to know how to block these two addresses 85.255.116.133
85.255.112.87
thank you

See this re renewal of IP address -

https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/problems_with_acquiring_or_renewing_the_ip_address-t6758.0.html

If you want to block IP addresses you can use the Microsoft Management Console as follows -

If you dont have control over a router or firewall you can block IP’s at the server via Windows.

Click ‘Start’ > ‘Run’ >type ‘MMC’ press ok.

In the console click > ‘File’ > ‘Add/Remove Snap in’

In the ‘Standalone Tab’ click The ‘add’ button

Seclect ‘IP Security Policy Managment’ > ‘ADD’ > ‘Local Computer’ > ‘finish’ > ‘close’ > ‘ok’

You should now be back to the console.

In the left frame right click ‘IP security policies on local computer’ > ‘Create IP security policy’

Click Next and then name your policy ‘Block IP’ and type a description.

Click ‘Next’ then leave ‘activate’ ticked then click ‘Next’

leave the 'edit properties ticked and click ‘Finish’

You should now have the properties window open.

Click ‘ADD’ then click ‘Next’ to continue.

Leave ‘This rule does not specify a tunnel’ selected and click ‘next’

Leave ‘all network connections’ selected and click ‘next’

You should now be on the IP filter list. You need to create a new filter, so dont select any of the default ones. Click ‘ADD’

Type a Name for your list, call it ‘IP block list’
Type a description in, can be same as name.
Click ‘ADD’ then click ‘Next’ to continue.

In the description box type a description. As its the first IP you are blocking call it ‘IP1’ or ‘IP Range 1’
Leave ticked the ‘Mirrored. Match packets with the exact opposite source and destination addresses’
Click ‘Next’

The ‘Source address’ should be left as ‘My IP address’ click ‘Next’

You can now select ‘A Specific IP address’ or ‘A Specific Subnet’ for the Destination address.
Type in the IP address you want to block and if blocking a subnet type in the subnet block. Click ‘next’

Leave the protocol type as ‘Any’ and click ‘Next’ and then ‘Finish’

You have now blocked your first IP or IP range.

You can also use the Hosts file. I use peer guardian as well. You can create your own lists for it.

Thank you imagine, I will give that a try, and thanks for the link.
Hopefully this will work.

http://[URL=http://img521.imageshack.us/img521/8906/screenshot00001bz6.png]

Please would someone look at these rules and let me know if I’m safe.
Thank you

Modem not renewing IP address, may be caused by not having a service enabled.

It happened to me before. Not only with Comodo. You have to have “DHCP Client Service” as automatic.

Thanks,
geko.

Thank you for that Geko but it is enabled.
I just need someone to look at my rules.

Please look at rules and let me know if I need to tighten up or if I’m ok.
Thank you