Modem Dialing Issue

After installing Comodo Personal Firewall, I experience errors when attempting to dial subsequent times in one session. The first dial will go alright but then after disconnecting and then reconnecting I receive TCP/IP error 31 from the modem or will get connected and the internet is not operational. This is fixed however by rebooting after every un-dial, however this is very inconvenient.

Any Ideas would be appreciated…

firewall2243: welcome to the forum (:WAV)

Try this site and see if any of those suggestions apply. I’m not sure if it’s firewall being the culprit. What you can do to start things off is temporarily set the Security Level to Allow All, then you know’ll it’s not CFP.

My personal (yet random) ideas are winsock repair and TCP/IP reinstall (for XP).

G’day,

I suspect that this might be caused by the firewall blocking your ISP allocating an IP address to your dial up connection on the subsequent connections.

Can you try something for me.

  1. Set the firewall to allow all
  2. Dial up your ISP.
  3. Click START - RUN. Type “CMD” and press enter.
  4. In the DOS-style window type “ipconfig /all”
    4a. This will show the current IP details.
  5. Find the section about your modem connection and note the IP address
  6. In the DOS window, type “exit” to close the window
  7. Disconnect
  8. Wait an hour or so and then repeat steps 2 to 7

Reply to this topic, quoting the IP addresses that were assigned to your modem in each of the two connection sessions

Hope this helps,
Ewen :slight_smile:

Thanks for the responses.

I uninstalled the firewall and the problem was fixed so it definitely is Comodo :frowning:

I tried TCPIP repair to no avail (not surprised since it doesn’t appear to be Window’s fault)

Also if it succeeds in dialing on subsequent attempts and does not give me TCPIP error 31 then I noticed there was an ip address…and as i tried to browse saw that the send packets was only increasing by a few and there was no return packets. Usually both increase by the thousand each time i browse a site.

in fact, turning off the firewall does not fix the problem either, it seems the Comodo service might be the culprit.

Perhaps this is a bug in Comodo…is anyone else who has a dialup modem having this problem?

Did you run through steps 1 to 8, as per my previous post, and what were the IP addresses allocated to your modem on each connection attempt?

Making the modem dial on successive occassions isn’t the problem, getting it to establish a connection on subsequent connection attempts is. We need to see what is happening during the second connection attempt. That’s why the steps were laid out the way they were.

Let us know.

Cheers,
Ewen

Sorry for the lateness of this reply, I’ve been away from my computer at work for a while…

On the first connection it shows an IP address clearly as data is transferred no problem

After waiting an hour I attempt to redial and it failed the first time to establish a connection returning error 31 however after another attempt I was able to connect and it also showed a valid IP address however no data was being returned.

I contacted the ISP service support (free luckily) and it turns out that when i disconnect, in some cases they log that the disconnect didn’t go through…which also has never happened to me until after installing Comodo which might explain some things however it still traces back to the firewall…

I’m pretty sure there is nothing wrong on my end as uninstalling does the trick and fixes my problem and I hate to always “Allow All” as that defeats the purpose of a firewall. Perhaps there is some bug in the Comodo firewall that is interrupting the dialup connections?

Thanks for the help guys in the previous posts I do appreciate it :slight_smile:

Hi, i have the same problem, when i try to connect to internet for the second time, it shows me the “error 31”… has anybody find a solution to that?I can’t find it and if i don’t understand how to solve the problem i will have to uninstall Comodo
Help me please
ps. i don’t speak english very very well, and i am also not so good at using computer so, please, be simply and clear… thanks!!!1