Missing CIS Icon in Tray, Vista 64

The subject pretty much says it. If I check the task manager, it shows CIS running, and Windows Security Center reports Comodo as both Firewall and AV handlers. Is this a known problem?

I can provide a little more history if that helps, but I was expected an easy install so wasn’t trracking events closely. Among other things:

  • installed first one version, tried to import rules, tried some things, had problems, uninstalled it
  • installed a second version, started noticing lack of icon
  • at one point noticed two cfp.exe processes in task manager
  • remembered that uninstall was a little sketchy so downloaded and used latest CIS Clean-up .bat from this forum
  • have tried with both 3.9 and the latest 3.10, all for x64, same result as now
  • at some point got a warning from windows that some startup item which needed to ask permission had been disabled (i took that to mean because there’s no facility for asking permission during startup)
  • I think something is botched but I had system restore turned off for defraging and resizing partitions, so no help there
  • I’ve been rebooting after every comodo change

Current status: right now it looks like it’s running at startup, but no icon in tray and I can’t open its management screen.

What should I do next? And how can I figure out which version is running without the management screen?


If it’s any help, I had a similar problem (XP 32-bit, though).

I opened the control centre by double-clicking on the desk-top short-cut icon. The Comodo system tray icon appeared, and seems to have worked since.

What happens if you double-click the CIS desktop icon? If it brings everything back as you wish it, then the file is not residing in the startup registry where it belongs.

When I d-click the desktop icon, I get the busy cursor and nothing else. If I open task manager, I see two cfp.exe processes (and I assume the second came from clicking the desktop icon). The Comodo window doesn’t open, and there’s no icon in the tray for Comodo.

Just reading the comments in the thread for the Clean-up tool … it looks like it’s not necessarily up to date with the latest two releases.

I’ll trying following the uninstall instructions here:


Using the regular old built-in Comodo uninstaller, when it finished uninstalling and gave the popup saying you need to reboot now, yes/no – then Vista displayed a popup saying some start items had been blocked for lack of permissions.

I was not able to click Vista’s message balloon in time to see the list of blocked items. It did leave a little “blocked items” icon in the task bar, but when I right-clicked on that it went away.

OK – paying close attention this time, here’s what I observed.

  1. Started by following full uninstall instructions
  1. Reboot again for good measure
  2. Now reinstall CIS 5.10.nnn.531
  3. Reboot
    • observe no CIS icon in tray
    • observe cfp.exe process in Task Manager
    • double-clicking CIS desktop icon gets second cfp.exe process but no UI
  4. Reboot
    • observe same as after last reboot
  5. Reboot
    • observe same as last reboot
  6. Reboot
    • same results
  7. Uninstall with CIS built-in installer
    – balloon popup “Windows has blocked some start-up programs. Click to view blocked.”
    – I clicked, but it didn’t show anything
    – clicking the “blocked” icon in the tray didn’t show anything either, it just went away.

That’s where I am now.

Does anyone have ideas, or am I going to have to reinstall Vista to get this to work / get back to a clean state?

Am I wrong to try and use CIS with Vista 64? Or am I just not doing it right? :slight_smile:

As always, thanks for any help.

You can mark this resolved. I went with a Vista reinstall.

This is what fixed that problem for me on Windows 7 Pro x64:
Go to the installation directory: C:\Program Files\COMODO\COMODO Internet Security
Right click cfp.exe
Click Properties, then click the compatibility tab
At the bottom where it says Privilege Level, make sure the item “Run this program as an Administrator” remains unchecked (unticked).
Click apply then restart.