Missing CFP 3 System Tray Icon [Merged Threads]

Installed “CFP_Setup_3.0.12.266_XP_Vista_x32” on Vista system and do not see system tray icon.

Where did it go?

After updating Comodo im missing the systray icon, I try et reinstalling comodo, restarting the computer, cliking icon on desktop and about everything else i can think of and i cant open comodo options.
I get popups from defender+ but thats about it.

Windows xp pro
AVG antivirus


first…please excuse my rookie english skills…
I just installed Comodo 3.0 and it seems to work (because defense+ is running etc etc) BUT I have no icons in the taskbar. I also can not access the configuration menu, nothing happens when I try to start the .exe (:SAD)

As virus scanner i am using Antivir atm, but the AV icon also disappeared from the taskbar.

I hope you can help me out, after 3 installs its always the same problem…


I have the same problem…and I am using the same antirus program. So I guess it is because of antivir…I will try deinstall and run comodo later.

Yep, when you uninstall Antivir the icon appears and you can access the configuration menu.

Ok I found out that it has something to do with the antirus program I use…then I switched to Comodo Antivirus and had the same problem.

Any idea?

Uninstalling AVG and then installing comodo did the it.

Note for others with the same problem, you can install AVG after installing comodo and then both works.

:frowning: I am having the same problem, but using McAfee v11 rather than AVG.

I can’t get the COMODO user interface up by any means, even double-clicking the desktop icon doesn’t work.

The firewall itself and Defense+ seem to be running OK, though.

I have tried several reboots and a reinstall and still haven’t managed to resolve this.

Don’t have time to try deinstalling/resinstalling McAfee today. Of course I shouldn’t need to go to this trouble anyway.

i have this problem, to get the system tray icon to show up i have to log out to the welcome screen and log back in after starting up the computer, this seems to be a problem with the windows system tray (i think) as it happened on xp as well.

also, i had issues installing avg free edition after installing comodo, comodo kept asking for permission to allow the avg setup to check every file it needs and every action it was performing. i had to forcibly shut down comodo to install avg, rebooted and everything works. I also found that defence+ was REALLY slowing down my comp (just like every other hips prog out there), and caused a few Blue Screens Of Death, so i set its slider to disabled. windows works fine and fast now.

I got the same problem after updating a few days ago. I solved as follow :

  • Opened Task Manager and killed the cfp.exe process.
  • Run Comodo Firewall using the short-cut on Desktop or Start menu. The systray icon appeared.

If the process cfp.exe is still running, click on the short-cuts of CF on Desktop or Start menu does nothing.

BTW, I had to do it once. Next time I restarted my computer, the icon appeared as expected.

Hope it works for you too.

k, first, some details:

  • firewall v3 latest version
  • cable internet connection
  • win xp sp2 + up to date patches
  • admin user
  • also use avast anti virus
  • removed comodo firewall v2.4 to install v3
  • not removed/changed anything since install

after installing v3, I cannot open the firewall to configure it. there is no icon showing in the systray. I do not have “hide inactive icons” set. the firewall is however running, as alerts pop up as per usual when connecting to the net.

double clicking desktop icon, or clicking icon in start menu does nothing, so I’ve no way to open the firewall.

I have since reinstalled CFP v3 using a new download, and the problem still prevails.

anyone have any ideas? as much as I like CFP, it’s no good to me if I cant open it! (:SAD)

Here is a “workaround”. Should not have to resort to this, but until Comodo fix’s the problem, here is what works for me:

V3 icon does not appear in the task bar. As a work around, I unselected CFW in “Startup” section of MSCONFIG (Start/Run/msconfig) and after bootup complete, start the firewall manually from the shortcut icon. Every startup, XP will whine that you are not in “normal” startup. I guess just live with it till fixed

Hope that helps

thanks for the suggestion, that got the control panel working. can edit the start up items in ccleaner or spybot s&d to get round that windows message.

it seems that CFP possibly resets to “load at startup”, may have to change that setting every time.

I used the misc/diagnostics to check my install and it said there was something wrong with it. having “fixed” it and restarted, my computer hung and beeped (:AGY)

that changed it back to “load at startup” too. but hopefully this will stay stable till they fix this.

I have installed Comodo Firewall v 3.

My PC runs Windows XP SP 2, and I cannot get the firewall’s icon to appear in my system tray.

When I check the Windows Task Manager, it shows that the firewall is running.

What can be done to correct this issue?

Thank you.

I just upgraded to Comodo firewall V.3. All is well, except the icon in the task tray no longer changes to indicate when I have “blocked all”. Is there a way to get that icon to change so I will now the security state without opening software?

I have the same question. If I turned of the firewall for some reason, the icon does not show it like in version 2. Any plans to change this?

Seen one or two other posts with this. I take it a reboot doesn’t bring it up??


I don’t know why but the icon of Comodo Firewall has disappeared from systray. When I use Ctrl/alt/del and look at the running process, cfp.exe is running …

Unable to kill it : operation failed, access refused.

Can someone tell me where the problem comes from ?


That’s correct. A reboot doesn’t bring it up.

i would try an uninstall and clean install, but thats just me, also make sure your taskbar is set to show all icons