MIRC sending a file

what can i do to avoid Comodo blocking mirc when i try to send a file?

Hello raf84dj.

I believe you will need to create an application rule to allow MIRC access to the IRC Network. CPF should do this for you the first time you run MIRC.

Go to Application Monitor and delete any rules for MIRC currently created. Restart your computer, then run MIRC. You should receive a prompt or two from CPF, which is asking if it should allow MIRC. If you select Allow and tick remember it should create the rules for you.

In essence you need a rule that allows TCP Out on Ports 6660-6669 and 7000.

I hope this helps.

Toggie

When u go to run Mirc for the 1st time, CPF will pop up, asking you to accept port 59 TCP.

Then once u log in, it’ll pop up again, asking for access to port 53 UDP.

Then the tricky bit is adding the dcc ports (under file menu/select server/connect/options/advanced).

This is what u have to configure in the firewall.

You dont have to add ports 6660-6669 or 7000 to the firewall. Its the DCC ports u have to add.

Altho, I tried this last night (after a format) and it doesnt work! Not too sure why coz dcc worked for me before, just by adding the DCC ports in XP’s firewall exceptions, I didnt have to add the dcc ports to the firewall at all.