Miktex is not able to update (CPF 3.0.17 X32)


I use Miktex as my LaTeX distribution. Today, I tried to update it. However, CPF keeps coming with alerts about update.tmp could not be recognized. Each time I start Miktex updater, I get three or four alerts about this. Of course, I select to remember my settings, but Miktex cannot connect. If I disable CPF, everything goes well.

  1. CPU (32 bit or 64 bit)
    Athlin 64 3000+ (64-bit)
  2. Operating System information (including Service Pack Version)
    Win XP SP2 NL 32-bit
  3. Actively-running security and utility applications
    Avg Free
  4. Specific symptoms of the bug, and steps you can take to reproduce it.
    See above
  5. Specific steps you have taken to try to resolve it.
    Disable Defense+ (didn’t work), disable firewall (did work)
  6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+
    Firewall: Train with safe, Defense+: Clean PC mode


I have few questions about this issue.

Can you take a screenshot of that alert?
Did you change your cfp alert level setting?
Can you reset yor cfp log and post a screenshot of any entries logged when the updater fails?
Can you take a screenshoot of D+ view active processes to show all Miktex related processes?

See attachments for alerts. If D+ is enabled, it keeps coming back with the alert (also atatched) (doesn’t matetr if I select ‘installer/updater’).
The firewall section of the logs has no entries about this (it has almost no entries at all).
Thanks for your help!

[attachment deleted by admin]

look for update.tmp D+ rule an set it to trusted or windows system app.

look for update.tmp Firewall rule and set it to trusted too

please attach ctxtoll.bat in a zipped file

Changing both to trusted solved the problem! However, I think I shouldn’t have to change those settings by hand? And where do I find ctxtoll.bat?

F:\Program Files\MiKTeX 2.6\scripts\context\stubs\mswin\ctxtolls.bat

Here it is

[attachment deleted by admin]

Glad you solved it. I looked at that bat file but I gained not much useful info it just run an interpreter (or alike) and a script.

Basically you can set update.tmp to trusted when you get the first alert which have the icon of that program on the left side of the alert.
Using a trusted policy is usually a quick trick to avoid alerts but you can try to add update.tmp to your d+ safe list to make v3 learn it and then remove it after it was learned.
But update.tmp should not be deleted in order for this to work. looking ay its .tmp extension this may not be the case.
That file could be deleted after the update end (even if it fails).

Another option would be to create a ruleset manually using filename and wildcarded rules. But this may be a bit difficult to do if Miktex run and creates a lot of files in order to update itself.
The usual option would be to mark all alert to be remembered but this may not work if Miktex creates a lot of new files with random names (eg ytrknw.tmp or alike)

So it’s up to you to chose the best way to handle this. I usually prefer to use trusted policies with D+ only in few cases.

I’m going to move this topic to the help board.