Mid-scan hang

I’ve just installed Comodo Firewall (works fine) & Antivirus. Every time I run the virus scan, it runs fine for a while but then hangs in the same place every time : it doesn’t close, it doesn’t throw up an error, it thinks it’s still scanning, but always hangs in the same directory. It does this at about 38,000 files.
My OS is XP (SP2).
Any ideas?

Welcome to the forums, Arkwright (:WAV)

Let me take a couple quick guesses, and we’ll see how close to the target I am…

You have CAVS 1.1.

It’s hanging in Documents & Settings, where you have some large folders (images, files, etc).

Does that sound about right?


Many thanks, LM, you’re spot on, on both counts. So what’s the prognosis - should I Abandon All Hope?

(PS By the way, when I looked for replies to my query, I got:
a) Hey, Arkwright, you have 0 messages, 0 are new. …Also-
b) No messages… (under “Show new replies to your posts.”)
I found your reply by Searching for my original msg & finding yours underneath.)

That’s odd, on the “no messages” thing. You can report that under website problems, here: https://forums.comodo.com/index.php/board,46.0.html I don’t think a topic exists at this point, so you might need to create a new one…

As to abandoning all hope, no you don’t need to. Glad I nailed it; that makes me feel good… ;D Ahh, well, it’s a known issue with CAVS 1.1. Been fixed with the current Beta of 2.x; that one should go public/final version in the near future.

I had the same problem, I’ll share with you what happened; it might work for you as well. It was with someone else’s files on the computer, so I couldn’t just delete them (something like: Docs & Settings/user/file/subfile, with multiple files within files, pics, pics in the files, subfiles, etc, such that the total was several Gigs of space). Comodo asked for copies so they could see why it was hanging. So, I copied all the files to another location so I could compact them, compress them and send them to Comodo. I couldn’t send or upload because compressed it was still over 2 Gigs. So, I started deleting all the copies. It hung on me several times, just trying to delete; very arduous.

Here’s the ticker, though ~ when I was done deleting all the copies of the original files, now CAVS was able to scan through without any problem, so I had nothing more to report! I don’t know if it was because of the layers of files, all with large amounts of pics etc, or what (although I’m guessing that’s what it was - I think if the files were all separate, it would’ve been okay). In other words, instead of c:\docs & settings\user\pics\a pics (32M)\b pics (200M)\c pics (85m) it should’ve been c:\docs & settings\user\pics\a pics, c:.…~\pics\b pics, etc. But since the problem seemed to have corrected itself, there was nothing more to check…

At any rate, the current Beta definitely has no problem with it. If you’re up for a Beta, you’re welcome to it. Just be aware it is a Beta, and as such could cause problems. Use at your own risk… :wink: I have not had any major problems with it; just minor annoyances. However, some users have experienced more major setbacks (that seem to be related to other issues, but are triggered by the Beta install/operation).

Hope this helps…


Dear LM

That really helps. I’ll download the beta 2.x tonight.

(And I’ll log the zero msgs error too!)

Many thanks indeed for your help.


No problem, Arkwright; I’m glad to help.


Ah - now I can’t find the version 2.x Beta on the Comodo site, only the 1.1
Do you know where I find it?



Oh yeah, I probably should’ve stated that clearly… The 2.x Beta is only available on the forums. The Beta forum is here: https://forums.comodo.com/index.php/board,61.0.html

The most current release is v., which is here: https://forums.comodo.com/index.php/topic,4731.0.html

I recommend reading through the various Bug Reports threads to get an idea of what some users are experiencing. The most debilitating is the hal.dll issue, which also has been experienced with v.1.1 as well (it can happen, apparently, with any software, depending on circumstances); I think Comodo is getting a good idea of how to resolve and prevent it.

If you give Beta 2.x a try, I’ll also refer you to this thread, written by yours truly: https://forums.comodo.com/index.php/topic,4755.0.html Some users (including me) experienced a major pain in the rear when trying to uninstall CAVS 1.1, due to the installer that Comodo packed it with (as soon as they identified the problem, they built their own, and provided some potential solutions - none of which worked for me). This thread explains step-by-step how I finally got it uninstalled.

If you have any questions, don’t be afraid to ask. (not that you would be, but just a reminder…:wink: )


Hello, I am a new user of the Comodo AntiVirus 1.1 since yesterday, and I have experienced a similar problem - but I have no clue how to solve it!

The Full System Scan hangs in a folder, and won’t continue scanning. The path however is not in the Documents & Settings, but the following: D:\LL\Arbete\Chalmers\Arkitektur\Studio Project 3 & 4\Final Delivery - ‘Finally a Central Harbour’. The folder contains 8 files (AI, PPS and DOC files), 126 MB of data. Does this give a hint why the scanner hangs? Or maybe I should try the 2.x Beta as well?

Lars (Sweden)

Lars, welcome to the forums!

If you choose to try 2.x Beta, I think you will find the problem resolved. However, my same statements apply regarding give the Beta a shot…

Comodo Support might be interested in the scan hang; it certainly seems a bit different to me, what with the path, file size, etc. You can file a ticket here: http://support.comodo.com


Little Mac,

Thank you! I have now submitted a ticket. Since the 1.1 version seems to be stable except for this certain problem, I’ll probably wait for a support answer or an updated version instead of downloading the 2.x. Keep up the good work!


Just for the record:
That same problem occurs when sending large attachments (about 2 MB) bij mail.
I had to “repair” my Pegasus Mail today…
How annoying…

What version of CAVS are you running, mrahk?

What firewall do you have (type and version)?

And lastly, what do you mean when you say you had to “repair” Pegasus Mail?



I use (updates so the current production version.

Currently I use no firewall. I’m thinking about going to use Comodo Firewall, but I’m not sure I do understand the firewall rules stuff (I run several server functions on my computer so I need to understand it how the rules work).

And concerning the repair action:
Well, Pegasus Mail stores mail in encrypted folders. I had to send a large attachment, but the virus scan didn’t work so the program crashed. This can damage the folders (and it did). So the damage is not a direct consequence of CAV, but at least you can say that CAV initiated the problem.

Thanks for the info, Mrahk.

I highly recommend Comodo’s firewall; I also understand your need to know how to make it work with your system, before installing and running into problems. You can post a question in the FW Help section, about using it with your setup, and I’m confident someone will be glad to help you out.

Would you submit your Pegasus/CAVS email scan issue to support? http://support.comodo.com/ They probably need to know about it. I know some other users use Pegasus, and I don’t recall this being reported in the forums (doesn’t mean it hasn’t, just that I haven’t seen it…).

You can turn outbound scanning off, if you want, and still have the mass-mailer feature on. I have read that some hold the position that email scanning can be hazardous to a system; the idea is that if you have on-access scanning, that should suffice. Apparently (according to some), actively scanning emails for viruses etc can cause some problems (I don’t remember what those were).