Microsoft Word doesn't save a modified file

Hi all,
Word denies saving modifications to an existing file.

This is what I did:

  1. Opened word
  2. added some text
  3. Saved under some name – so far, so good. Also, saving again at this point without any change to the file works OK.
  4. With the file still open (but the same happens if I close and re-open) I added some more text and clicked Save.
  5. Word popup: “Word cannot complete the save due to a file permission error. (E:\wrd.doc)”
  6. In E:\ I now have (instead of the two files “wrd.doc” and “~$wrd.doc” I had previously): “~$wrd.doc” and “Backup of wrd.wbk”. No “wrd.doc” once I attempt to save.

D+ security levels don’t have any effect on the above behavior.
There are no active rules for Word, and I accepted every D+ popup with “Remember”.
Using the app as Trusted doesn’t help.

Could someone please help get this resolved?

Thank you.

First, delete any policy you may have for MS Word (at #4, instead of editing the policy, remove it):;msg220242#msg220242

Then change the D+ config to “Training Mode”, run MS Word, do all you want, and after closing Word change the config back to the one you had it on before (look at the 2nd part of the guide):;msg216056#msg216056

Thank you very much for your detailed response.
I have since restored a saved system image that had no firewall at all, and installed CIS. Then I picked Proactive Security, selected Training mode, and started Word.
The exact same thing happened.
I am running XP SP2+ Pro installed from an nLite’d image. While this latter may seem a plausible culprit, this same system has no problems when running Online Armor or Outpost firewall.

I have saved an image of my system with Comodo installed, so I’ll restore it, follow your advice and links, and report back with the results.

I’d hate to not be able to use Comodo. I have been using Outpost for the past 5+ years, but I could only achieve 150/340 in the Comodo Firewall Test, and that shattered my confidence in it. CIS is the only firewall today that offers at least the same granularity in creating network rules that Outpost provides, plus the HIPS functionality. Regardless of my problem with it, here is a big thank you to the company and the developers for this dream of a firewall.

Hmmm…have you tried disabling D+?

See attached (right click on the tray icon {shield in the lower right corner} > Hover over “D+ Security level” > select “Disabled”).

[attachment deleted by admin]

I was too paranoid to do that (:LGH)
But I’ll try it (in fact, anything) over the weekend when I restore that system image.

Oh BTW (and !ot!), what do you use to make system images?

Oh BTW (and ), what do you use to make system images?
Acronis. And [b]always[/b] full image, never incrementals.

I have reinstalled CIS on a clean system (well, clean at least from any other protection software), and found this:
Whatever the mode for protection level, firewall, antivirus, Microsoft Word is unable to save a modified file.
Also tried using Word as an Installer or a system file.
Also tried turning off all protection.

  1. Created a new Word file and typed some text, then saved the file – so far, so good:

  2. Then modified the file and tried to save it again – no go:

    Notice how the .doc file dieappeared – now only the .wbk file exists. No idea why.

  3. Tried Excel and some ASCII editors - all work fine and can save over an existing file.

  4. No such problem when using Outpost or Online Armor.

Running XP Pro English SP2+ nLited.
If you have any idea what is wrong on my end, please help. HELP !!! (:AGY) (:AGY) (:AGY)