Microsoft Exchange Conflict

I use Comodo VPN to allow remote users direct access to our Microsoft Exchange server. The software works perfectly between computers and there is no issue with that. The conflict is when remote users attempt to read their email using a smart phone. With Comodo running on our server, the phones are not able to access it. If I exit Comodo the phones are able to connect.

Is there some sort of workaround for this? I don’t know if there is a port conflict but I would assume not. I figure that Comodo would avoid using standard windows ports for anything. We use dyndns to provide access to our phones.

Any help would be appreciated!

Okay, just in case anyone is interested in the solution I found for this problem. As it turns out, this was not an issue with Exchange and the ports that Windows was using. The conflict was the virtual network adapter that was installed with Comodo and the priority order of that adapter. Windows has to assign a priority to any adapter installed so it knows which order to use them in. Most people probably never have a problem because Windows automatically assigns this priority and it usually just works. In my case, Windows was making the new adapter the number one priority and as a result it did not know how to route my exchange request. IP addresses are different of course and there are probably other issues that resulted I was not aware of. The fix ended up being really easy. (This is for Windows Server 2003 or Windows XP).

Open the network connections
Under the “advanced” pull down menu, select “Advanced Settings”
You should be on the “Adapters and Bindings” tab
In the “Connections” area you will see a list of your adapters and the highest priority is at the top of the list.
Use the arrows on the right side to move adapters up and down the list
Click OK to make your changes effective. Everything should update immediately and there is no need to reboot.

Here is the link to Microsoft’s official technical article: